<!DOCTYPE html>
<!--[if lt IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 8]><html lang="en" class="no-js lt-ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 9]><html lang="en" class="no-js ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#" ><![endif]-->
<!--[if gt IE 8]><!--><html lang="en" class="no-js" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><!--<![endif]-->
<head>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1030601-4"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'UA-1030601-4',{  
  'custom_map': {'dimension2': 'pubdate'}
});
</script>

<script type="text/javascript">_atrk_opts={atrk_acct:"7CIsk1acBb00OC",domain:"nation.co.ke",dynamic:!0};(function(){var as=document.createElement('script');as.type='text/javascript';as.async=!0;as.src="https://certify-js.alexametrics.com/atrk.js";var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as,s)})();</script><noscript><img src="https://certify.alexametrics.com/atrk.gif?account=7CIsk1acBb00OC" style="display:none" height="1" width="1" alt="alexa"/></noscript>

<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<meta name="google-site-verification" content="bpM21xTzIpu_rdMgMeiN9tKlX_lDX_N44hD_YFzbT1s" />
<script type="text/javascript" src="https://cdn.nation.co.ke/dmp/bluekai-dfp-header-integration.js"></script><meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="msvalidate.01" content="EAEA2E15D93BC2979D58720786AF2DDB" />
<meta name="alexaVerifyID" content="e8s521zf2lW3kSQNwGY2XMME5No" />
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" /><meta name="viewport" content="width=device-width,initial-scale=1">
<meta name="robots" content="index, follow">
<script>gtag('event', 'pubdate_dimension', {'pubdate': "2020-01-10 06:00:00"});</script>
<title>Balala team should run Nairobi, MCAs now tell State - Daily Nation</title>
<meta name="description" content="They are pushing for the revival of Nairobi Regeneration Committee to take over." />
<meta name="keywords" content="Nairobi Regeneration Committee, Special Sitting, Beatrice Elachi," /><meta property="fb:app_id" content="174023979648743" />
<meta property="fb:pages" content="105983259496" />
<meta property="og:site_name" content="Daily Nation" />
<meta property="og:type" content="article" /><meta property="og:title" content="Nairobi MCAs ask State to help run capital city" />
<meta property="og:url" content="https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html" />
<meta property="og:description" content="They are pushing for the revival of Nairobi Regeneration Committee to take over." />
<meta property="og:locale" content="en_UK" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2020-01-10 06:00:00" />
<meta property="og:article:modified_time" content="2020-01-10 07:06:51" />
<meta property="og:image" content="https://www.nation.co.ke/image/view/-/5392778/medRes/2519552/-/yr5j2p/-/sonko-pic.jpg" />
<meta property="og:image:width" content="425" />
<meta property="og:image:height" content="262" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@dailynation" />
<meta name="twitter:title" content="Nairobi MCAs ask State to help run capital city" />
<meta name="twitter:description" content="They are pushing for the revival of Nairobi Regeneration Committee to take over." />
<meta name="twitter:image" content="https://www.nation.co.ke/image/view/-/5392778/medRes/2519552/-/yr5j2p/-/sonko-pic.jpg" />
<meta name="twitter:url" content="https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html" />
<script type="application/ld+json">{"@context": "http:\/\/schema.org","@type": "NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.nation.co.ke\/news\/politics\/Nairobi-MCAs-throw-Sonko-under-the-bus\/1064-5412880-joilrk\/index.html"},"headline": "Nairobi MCAs ask State to help run capital city","alternativeHeadline": "Balala team should run Nairobi, MCAs now tell State","image": {"@type": "ImageObject","url": "http:\/\/www.nation.co.ke\/image\/view\/-\/5392778\/medRes\/2519552\/-\/yr5j2p\/-\/sonko-pic.jpg","height": 424,"width": 696},"datePublished": "2020-01-10 06:00:00","dateModified": "2020-01-10 07:06:51","author": {"@type": "Person","name": ["COLLINS OMULO"]},"publisher": {"@type": "Organization","name": "Daily Nation","logo": {"@type": "ImageObject","url": "http:\/\/www.nation.co.ke\/nationmedia\/css\/icons\/dnmobile\/dnlogo.png","width": 40,"height": 29}},"description": "They are pushing for the revival of Nairobi Regeneration Committee to take over."}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[[{"@type":"ListItem","position":1, "item":{"@id":"http:\/\/www.nation.co.ke","name":"Home"}},{"@type":"ListItem","position":2, "item":{"@id":"http:\/\/www.nation.co.ke\/news\/1056-1056-u6geog\/index.html","name":"News"}},{"@type":"ListItem","position":3, "item":{"@id":"http:\/\/www.nation.co.ke\/news\/politics\/1064-1064-4f88toz\/index.html","name":"Politics"}}]]}</script><link rel="canonical" href="https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html" />
<link rel="amphtml" href="https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-view-asAMP-qbh6goz/index.html"><link rel="publisher" href="https://plus.google.com/117103205968039363033" /><link href="https://www.nation.co.ke/nationmedia/css/icons/dnmobile/apple-touch-icon.png" />
<link rel="apple-touch-icon" sizes="120x120" href="https://www.nation.co.ke/nationmedia/css/icons/dnmobile/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon" sizes="144x144" href="https://www.nation.co.ke/nationmedia/css/icons/dnmobile/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon" sizes="152x152" href="https://www.nation.co.ke/nationmedia/css/icons/dnmobile/apple-touch-icon-152x152.png" />
<link rel="stylesheet" href="https://www.nation.co.ke/nationmedia/css/fonts/fonts.css" type="text/css" media="screen" />
<link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet">
<link rel="stylesheet" href="https://secure.widget.cloud.opta.net/v3/css/v3.core.opta-widgets.css">
<link rel="stylesheet" href="https://secure.widget.cloud.opta.net/v3/css/v3.football.opta-widgets.css">
<link rel="shortcut icon" href="https://www.nation.co.ke/favicon.ico" type="image/x-icon" /><script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<script type="text/javascript" src="/code/view/DailyNation/-/1949308/-/3sj01u/-/modernizr-2.6.2.min.js" async></script>
<script src="/code/view/DailyNation/-/3797660/-/11l9hi4/-/jquery-3.1.1.min.js.js" async></script>
<script>if (!window.jQuery) { document.write('<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.0/jquery.min.js" async><\/script>');}</script>
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/1949856/-/3sj43i/-/normalize.min.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/4100284/-/vok37lz/-/main-dn-styles-v1.7.6.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/3783938/-/11kk8m2/-/election-css-v1.0.3.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/3783936/-/11kk8m0/-/camera-css.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/3783940/-/11kk8mp/-/owl-carousel.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/4239968/-/v3gbgtz/-/latestPopup.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/4107482/-/vof6ejz/-/vidStyle-v1.1.3.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/4221316/-/v48jqqz/-/GoogleSearchKe.css" />
<link rel="stylesheet" href="/code/view/DailyNation/-/416/-/8re5q6z/-/print.css" type="text/css" media="print"><script type="text/javascript">
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63208; // ACCOUNT NUMBER
  _sf_async_config.domain = 'nation.co.ke'; // DOMAIN
  _sf_async_config.flickerControl = false;
  
		_sf_async_config.useCanonical = false;
		_sf_async_config.useCanonicalDomain = false;
	  
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script></head>
<body>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<header class="navbar full-width noprint">
<nav class="container">
<a href="/1148-1148-hfsx23z/index.html" class="logo"></a>

<ul id="panel">
<li>
<a href="/news/1056-1056-u6geog/index.html">News</a></li>
<li>
<a href="/business/996-996-x0uutpz/index.html">Business</a></li>
<li>
<a href="/counties/1107872-1107872-44rd16z/index.html">Counties</a></li>
<li>
<a href="/sports/1090-1090-iqcgwe/index.html">Sports</a></li>
<li>
<a href="/oped/1192-1192-110kbth/index.html">Blogs &amp; Opinion</a></li>
<li>
<a href="/lifestyle/1190-1190-5p56avz/index.html">Life &amp; Style</a></li>
<li>
<a href="/video/1951480-1951480-1072vroz/index.html">Videos</a></li>
<li>
<a href="/photo/1951220-1951220-df7whxz/index.html">Photos</a></li>
</ul>

<ul>
<li>
<a href="/news/1056-1056-u6geog/index.html">News</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/news/politics/1064-1064-4f88toz/index.html">Politics</a><a href="/news/africa/1066-1066-oo1nedz/index.html">Africa</a><a href="/news/world/1068-1068-y0kl4cz/index.html">World</a></div>
<div class="main column">
<h4>Latest News</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/news/Experts-market-locusts-as-healthy-food/1056-5412862-tbso70/index.html"><img src="/image/view/-/5412872/lowRes/2532044/-/mmqcd8z/-/LOCPIC.jpg" alt="Desert locusts invade Gurar in Wajir North. The insects are a" />
</a></figure>
<a href="/news/Experts-market-locusts-as-healthy-food/1056-5412862-tbso70/index.html">Experts market locusts as healthy food</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html"><img src="/image/view/-/5392778/lowRes/2519551/-/1087mpa/-/sonko-pic.jpg" alt="Nairobi Governor Mike Sonko at Milimani Law Courts on December 11," />
</a></figure>
<a href="/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html">Nairobi MCAs ask State to help run capital city </a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/news/New-NHIF-rules-to-hit-voluntary-members/1056-5412898-11dmnsxz/index.html"><img src="/image/view/-/5205214/lowRes/2401409/-/vn9g8c/-/ATWPIC.jpg" alt="The front entrance of the NHIF building in Nairobi.  FILE PHOTO |" />
</a></figure>
<a href="/news/New-NHIF-rules-to-hit-voluntary-members/1056-5412898-11dmnsxz/index.html">New NHIF rules to hit voluntary members</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/news/africa/Voodoo-makes-a-comeback-in-its-Benin-home/1066-5412944-pooabz/index.html"><img src="/image/view/-/5412946/lowRes/2532108/-/5poeys/-/benin.jpg" alt="The Vodoun priestesses give offerings to a sacred Vodoun idol in" />
</a></figure>
<a href="/news/africa/Voodoo-makes-a-comeback-in-its-Benin-home/1066-5412944-pooabz/index.html">Voodoo makes a comeback in its Benin home - PHOTOS</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/business/996-996-x0uutpz/index.html">Business</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/business/seedsofgold/2301238-2301238-e2g5gz/index.html">Seeds of Gold</a></div>
<div class="main column">
<h4>Latest Business</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/business/seedsofgold/technologies-to-redefine-farming-in-this-decade/2301238-5412532-15ryw2cz/index.html"><img src="/image/view/-/5412550/lowRes/2531921/-/27b049/-/greenhouse+tech+img.jpg" alt="In this past photo, Mechatronics Engineering students Denzel" />
</a></figure>
<a href="/business/seedsofgold/technologies-to-redefine-farming-in-this-decade/2301238-5412532-15ryw2cz/index.html">New cutting-edge technologies to redefine farming in this decade</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/business/KCB-injects-Sh5bn-into-National-Bank-to-shore-up-capital/996-5411976-8kpu0z/index.html"><img src="/image/view/-/5411978/lowRes/2531561/-/23lyciz/-/kampic.jpg" alt="The National Bank branch on Kenyatta Avenue, Nairobi. KCB had" />
</a></figure>
<a href="/business/KCB-injects-Sh5bn-into-National-Bank-to-shore-up-capital/996-5411976-8kpu0z/index.html">KCB pumps Sh5bn into National Bank</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/business/Boda-boda--tuk-tuk-imports/996-5411832-my8xr3z/index.html"><img src="/image/view/-/5411834/lowRes/2531468/-/ygg75r/-/boda.jpg" alt="Boda boda operators: Growth in motorbike imports defies tough" />
</a></figure>
<a href="/business/Boda-boda--tuk-tuk-imports/996-5411832-my8xr3z/index.html">Boda boda, tuk tuk imports hit Sh10bn</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/business/Suspected-arsonists-set-fire-to-Mumias-Sugar-cane/996-5410788-10uj7hi/index.html"><img src="/image/view/-/5410814/lowRes/2530861/-/ygefpz/-/msc.jpg" alt="The entrance to Mumias Sugar Company. PHOTO | FILE | NATION MEDIA" />
</a></figure>
<a href="/business/Suspected-arsonists-set-fire-to-Mumias-Sugar-cane/996-5410788-10uj7hi/index.html">Suspected arsonists torch Mumias Sugar cane</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/counties/1107872-1107872-44rd16z/index.html">Counties</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/counties/coast/3347800-3347800-ey6rn8z/index.html">Coast</a><a href="/counties/northern-region/3347734-3347734-155vfigz/index.html">Northern</a><a href="/counties/eastern-region/3347810-3347810-2501vq/index.html">Eastern</a><a href="/counties/mtkenya/3317830-3317830-7p8g5w/index.html">Mt Kenya </a><a href="/counties/north-rift/3347778-3347778-aga2m3z/index.html">North Rift</a><a href="/counties/south-rift/3347782-3347782-rtpd5y/index.html">South Rift</a><a href="/counties/western-region/3347786-3347786-nvg1d5/index.html">Western</a><a href="/counties/nyanza-kisii-region/3347796-3347796-unywdg/index.html">Nyanza-Kisii</a><a href="/counties/nairobi/1954174-1954174-swx4nez/index.html">Nairobi</a></div>
<div class="main column">
<h4>Latest Counties</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/counties/nyeri/Dreaded-detention-camp-turned-into-school/1954190-5412524-r2mkfjz/index.html"><img src="/image/view/-/5412542/lowRes/2531924/-/13r632r/-/DETPIC.jpg" alt="These houses at Kangubiri Girls High School in Nyeri were used as" />
</a></figure>
<a href="/counties/nyeri/Dreaded-detention-camp-turned-into-school/1954190-5412524-r2mkfjz/index.html">Dreaded detention camp turned into school</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/counties/meru/No-Locusts-in-Meru--county-official-says/1183302-5412968-wdgdwlz/index.html"><img src="/image/view/-/5413008/lowRes/2532122/-/1304y5d/-/locust-pic.jpg" alt="Agriculture Executive says insects seen by locals were green" />
</a></figure>
<a href="/counties/meru/No-Locusts-in-Meru--county-official-says/1183302-5412968-wdgdwlz/index.html">No locusts in Meru, County official says</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/counties/embu/Burial-aborts-after-man-is-found-alive/3370188-5412616-97kq3xz/index.html"><img src="/image/view/-/5412620/lowRes/2531967/-/cahdg9z/-/1.jpg" alt="The burial programme of Stephen Kivuti who was assumed dead by his" />
</a></figure>
<a href="/counties/embu/Burial-aborts-after-man-is-found-alive/3370188-5412616-97kq3xz/index.html">Burial aborts after man is found alive </a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/counties/kitui/TSC-withdraws-teachers-from-school-after-tutor-lynched-/3444936-5412404-sy7qiy/index.html"><img src="/image/view/-/5412358/lowRes/2531874/-/12kid1tz/-/Teacher2.jpg" alt="An undated picture of Daisy Mbaluka Mbathe, the teacher of Ndooni" />
</a></figure>
<a href="/counties/kitui/TSC-withdraws-teachers-from-school-after-tutor-lynched-/3444936-5412404-sy7qiy/index.html">TSC recalls staff after teacher&#039;s brutal murder</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/sports/1090-1090-iqcgwe/index.html">Sports</a><section class="mega-menu">
<div class="row">
 <div class="aside column sub-menu">
<a href="/sports/football/1102-1102-5p3gunz/index.html">Football</a><a href="/sports/athletics/1100-1100-g06rtez/index.html">Athletics</a><a href="/sports/rugby/1106-1106-g0i5l0z/index.html">Rugby</a><a href="/sports/golf/1104-1104-hjqyif/index.html">Golf</a><a href="/sports/othersports/1951306-1951306-fy284lz/index.html">Others</a><a href="/sports/talkup/441392-441392-wkoe7h/index.html">TalkUp</a></div>
<div class="main column">
<h4>Latest Sports</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/sports/athletics/Wada-sends-Russia-case-to-CAS/1100-5413036-bp6angz/index.html"><img src="/image/view/-/5364366/lowRes/2501711/-/e8h6lu/-/dope.jpg" alt="The logo of World Anti-Doping Agency (Wada) at the headquarters of" />
</a></figure>
<a href="/sports/athletics/Wada-sends-Russia-case-to-CAS/1100-5413036-bp6angz/index.html">Wada sends Russia case to CAS</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/sports/football/Atletico-stun-Barca-to-set-up-all-Madrid-Super-Cup-final/1102-5413024-xaq4pf/index.html"><img src="/image/view/-/5413030/lowRes/2532128/-/ti3v84/-/atletico_pix.jpg" alt="Atletico&#039;s players celebrate their win during their Spanish Super" />
</a></figure>
<a href="/sports/football/Atletico-stun-Barca-to-set-up-all-Madrid-Super-Cup-final/1102-5413024-xaq4pf/index.html">Atletico stun Barca to set up all-Madrid Super Cup final</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/sports/football/Kenya-international-poised-for-Nkana-move/1102-5413010-5wivqf/index.html"><img src="/image/view/-/5186908/lowRes/2390128/-/3aqqpuz/-/abuya_pix.jpg" alt="Kariobangi Sharks&#039; Duke Abuya celebrates his goal against Everton" />
</a></figure>
<a href="/sports/football/Kenya-international-poised-for-Nkana-move/1102-5413010-5wivqf/index.html">Kenya international poised for Nkana move</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/sports/Paul-Bitok-Mercy-Moim-speak-Malkia-Strikers-seal-Olympics-return/1090-5412710-13kg3xo/index.html"><img src="/image/view/-/5412588/lowRes/2531933/-/1q3782/-/bitok_pix.jpg" alt="Kenya coach Paul Bitok gestures during their Olympics qualifier" />
</a></figure>
<a href="/sports/Paul-Bitok-Mercy-Moim-speak-Malkia-Strikers-seal-Olympics-return/1090-5412710-13kg3xo/index.html">Bitok, Moim speak after Malkia Strikers seal Olympics return</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/oped/1192-1192-110kbth/index.html">Blogs &amp; Opinion</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/oped/blogs/620-620-obkqwq/index.html">Blogs</a><a href="/oped/opinion/440808-440808-h8w00fz/index.html">Commentaries</a><a href="/oped/editorial/440804-440804-id1ldp/index.html">Editorial</a><a href="/oped/cartoon/454986-454986-14tce6c/index.html">Cartoons</a></div>
<div class="main column">
<h4>Latest Blogs & Opinion</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/oped/opinion/We-should-transform-the-way-we-do-things/440808-5412822-6rljx3/index.html"><img src="/image/view/-/5412848/lowRes/2532038/-/59opoy/-/MUTPIC.jpg" alt="Lawyer and activist Miguna Miguna. This would be a lovely year if" />
</a></figure>
<a href="/oped/opinion/We-should-transform-the-way-we-do-things/440808-5412822-6rljx3/index.html">MATHIU: I hope this is the year that will transform the way we do</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/oped/opinion/Let-us-tackle-graft-causes--not-symptoms/440808-5412674-1m0u8cz/index.html"><img src="/image/view/-/5412688/lowRes/2531992/-/h8c486z/-/TWAPIC.jpg" alt="Kisumu residents protest against runaway corruption, at Kenyatta" />
</a></figure>
<a href="/oped/opinion/Let-us-tackle-graft-causes--not-symptoms/440808-5412674-1m0u8cz/index.html">MBARAK: Let’s tackle graft causes, not symptoms</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/oped/opinion/Tribute-to-critical-readers-who-keep-journalists-on-their-toes/440808-5412722-8ihoas/index.html"><img src="/image/view/-/5412754/lowRes/2532004/-/74oygt/-/MWAPIC.jpg" alt="He does not let journalists say anything that is untrue, unfair or" />
</a></figure>
<a href="/oped/opinion/Tribute-to-critical-readers-who-keep-journalists-on-their-toes/440808-5412722-8ihoas/index.html">MWAURA: Tribute to critical readers who keep journalists on their</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/oped/opinion/Nation-Readers-have-their-say/440808-5412776-2i5jt6z/index.html"><img src="/image/view/-/5412806/lowRes/2532026/-/3ewl6i/-/reapic.jpg" alt="A trader washes gunny bags at Nairobi River, at Grogan area, on" />
</a></figure>
<a href="/oped/opinion/Nation-Readers-have-their-say/440808-5412776-2i5jt6z/index.html">Readers have their say</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/lifestyle/1190-1190-5p56avz/index.html">Life &amp; Style</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/lifestyle/artculture/1954194-1954194-7hp6o1/index.html">Art & Culture</a><a href="/lifestyle/family/1954198-1954198-jeojfi/index.html">Family</a><a href="/lifestyle/health/1954202-1954202-rynt7v/index.html">Health</a><a href="/lifestyle/showbiz/1950810-1950810-25qq0az/index.html">Showbiz</a><a href="/lifestyle/travel/1950822-1950822-ry3yf4/index.html">Travel</a><a href="/lifestyle/women/1950830-1950830-b0uq99z/index.html">Women & Style</a><a href="/lifestyle/magazines/2439396-2439396-u46yvl/index.html">Magazines</a></div>
<div class="main column">
<h4>Latest Life & Style</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/lifestyle/mynetwork/I-take-the-frontline-in-settling-family-feuds/3141096-5412502-14oyhkwz/index.html"><img src="/image/view/-/5412528/lowRes/2531906/-/aoc302/-/Anne.jpg" alt="Anne Agambi has been an advocate of the High Court for more than 15" />
</a></figure>
<a href="/lifestyle/mynetwork/I-take-the-frontline-in-settling-family-feuds/3141096-5412502-14oyhkwz/index.html">Anne Agimba: I take the frontline in settling family feuds</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/lifestyle/mynetwork/Refresh-your-career-in-2020/3141096-5412534-fgoh0v/index.html"><img src="/image/view/-/5412556/lowRes/2531915/-/pn55a6/-/career+growth.jpg" alt="Without continued growth and progress, such words as improvement," />
</a></figure>
<a href="/lifestyle/mynetwork/Refresh-your-career-in-2020/3141096-5412534-fgoh0v/index.html">Refresh your career in 2020</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/lifestyle/mynetwork/What-is-the-difference-between-a-pension-scheme-and-gratuity-/3141096-5412666-ird85r/index.html"><img src="/image/view/-/5412686/lowRes/2531980/-/272uwf/-/pic.jpg" alt="Pension is a scheme where the employer and employee contribute" />
</a></figure>
<a href="/lifestyle/mynetwork/What-is-the-difference-between-a-pension-scheme-and-gratuity-/3141096-5412666-ird85r/index.html">ASK HER: What is the difference between a pension scheme and</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/lifestyle/mynetwork/-Help--My-boss-keeps-ignoring-suggestions-I-make-in-meetings/3141096-5412670-229ufw/index.html"><img src="/image/view/-/5025188/lowRes/2281086/-/40ma5f/-/BadBoss.jpg" alt="

A bad boss. PHOTO| FILE| NATION MEDIA GROUP" />
</a></figure>
<a href="/lifestyle/mynetwork/-Help--My-boss-keeps-ignoring-suggestions-I-make-in-meetings/3141096-5412670-229ufw/index.html">ASK HR: Help. My boss keeps ignoring suggestions I make in meetings</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/video/1951480-1951480-1072vroz/index.html">Videos</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
</div>
<div class="main column">
<h4>Latest Videos</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure>
<a href="/video/news/4146788-5412702-1fgrok/index.html"><img src="https://img.youtube.com/vi/EeL9an1xi-E/mqdefault.jpg" alt="Homa Bay governor, county officials issue joint statement on BBI" />
</a></figure>
<a href="/video/news/4146788-5412702-1fgrok/index.html"><span>11
&nbsp;hours&nbsp;ago</span>
Homa Bay governor, county officials issue joint statement on BBI</a></div>
<div class="story-teaser tiny-teaser">
<figure>
<a href="/video/news/4146788-5412698-1fgr59/index.html"><img src="https://img.youtube.com/vi/qnlcsSdDTcY/mqdefault.jpg" alt="Embu man speaks on return of his son who had been presumed dead" />
</a></figure>
<a href="/video/news/4146788-5412698-1fgr59/index.html"><span>11
&nbsp;hours&nbsp;ago</span>
Embu man speaks on return of his son who had been presumed dead</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure>
<a href="/video/news/4146788-5412694-1fgr55/index.html"><img src="https://img.youtube.com/vi/x81zEyiQuw0/mqdefault.jpg" alt="Final farewell in Mombasa for renowned Scholar Prof Harith Swaleh" />
</a></figure>
<a href="/video/news/4146788-5412694-1fgr55/index.html"><span>11
&nbsp;hours&nbsp;ago</span>
Final farewell in Mombasa for renowned Scholar Prof Harith Swaleh</a></div>
<div class="story-teaser tiny-teaser">
<figure>
<a href="/video/news/4146788-5412426-1fgpe3/index.html"><img src="https://img.youtube.com/vi/k-blNxJaIEA/mqdefault.jpg" alt="Dr Robin Mwenda of Mikidani Hospital, Mombasa speaks on the missing" />
</a></figure>
<a href="/video/news/4146788-5412426-1fgpe3/index.html"><span>15
&nbsp;hours&nbsp;ago</span>
Dr Robin Mwenda of Mikidani Hospital, Mombasa speaks on the missing</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/photo/1951220-1951220-df7whxz/index.html">Photos</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
</div>
<div class="main column">
</div>
</div>
</section>
</li>
</ul>

<a class="btn-slide"><i class="fa fa-bars" aria-hidden="true"></i></a>

<div class="search-form clearfix">
<form id="searchHeader" name="searchfrm" action="/page/search/DailyNation/news/politics/1064-1064-view-asGoogleSearch-iu24kd/index.html" method="get"><input name="q" type="search" placeholder="Search" />
<input type="submit" name="" value="" />
<input name="contextsIds" type="hidden" value="1148" />
<input name="sortBy" type="hidden" value="maupublicationdate" />
<input name="docTypes" type="hidden" value="&quot;MauArticle,MauGallery,MauVideo,CMDownload&quot;" />
</form></div>
</nav>
</header>
<article role="main" class="wrapper newsplex-article">

<section class="top-ad full-width">
<div class="container">
</div>
</section>

<section role="main" class="main-home artTop ">
<section class="top-ad full-width">
<div class="container">
<!-- google_ad_section_start -->
<script> 
var domainpath=window.location.pathname.split( '/' );

var Url_Seg1=window.location.pathname.split( '/' )[1];


if(domainpath.length>4){      



 if(Url_Seg1==="sports"){
  googletag.cmd.push(function() {

window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }
    googletag.defineSlot('/1010816/Z-DN-SportsBillBoard', [970, 250], 'div-gpt-ad-1566366272986-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

}



else{



 

if(domainpath.length==5 && Url_Seg1!=="news" &&  Url_Seg1!=="business"  && Url_Seg1!=="lifestyle"  && Url_Seg1!=="oped" && Url_Seg1!=="brandbook" && Url_Seg1!=="nationprime" ){ 

googletag.cmd.push(function() {


window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [[970, 90], [728, 90]]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();
googletag.defineSlot('/1010816/DN-slimmy-950x65', [[970, 90], [728, 90], [300, 250]], 'div-gpt-ad-1493111126853-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();

});







}





}



  }else{





 if(Url_Seg1==="sports"){
  googletag.cmd.push(function() {

window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }
    googletag.defineSlot('/1010816/Z-DN-SportsBillBoard', [970, 250], 'div-gpt-ad-1566366272986-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });

}

else{
googletag.cmd.push(function() {


window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [[970, 90], [728, 90]]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();
googletag.defineSlot('/1010816/DN-slimmy-950x65', [[970, 90], [728, 90], [300, 250]], 'div-gpt-ad-1493111126853-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());


googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();

});
}



}
</script>

<div id='div-gpt-ad-1493111126853-0' style='margin:0 auto;height:auto'>
<script>
if(domainpath.length>4){  



if(domainpath.length==5 && Url_Seg1!=="news" &&  Url_Seg1!=="business"  && Url_Seg1!=="lifestyle"  && Url_Seg1!=="oped"){ 

googletag.cmd.push(function() { googletag.display('div-gpt-ad-1493111126853-0'); });

}



}else{

if(Url_Seg1==="sports"){}else{
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1493111126853-0'); });

}
}
</script>
</div>

<div id='div-gpt-ad-1566366272986-0' style='height: auto;margin:3px auto 0px auto;'>
<script>

if(Url_Seg1==="sports"){
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1566366272986-0'); });

}else{}
  </script>
</div>
<!-- google_ad_section_end -->
</div>
</section>

<section class="">
<div class="container">
<div class="row">

<article class="main column">
<section class="ad noprint">
<div class="ad">
<!-- google_ad_section_start -->
<script>

var Url_Seg1=window.location.pathname.split( '/' )[1];

 if(Url_Seg1==="sports"){ }else{
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();





window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }








googletag.defineSlot('/1010816/Z-DN-728x90-ArticleTop',[[728, 90], [300, 250]], 'div-gpt-ad-1489467324804-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();
});



}
</script>

<div id='div-gpt-ad-1489467324804-0' style='margin:0 auto;height:auto'>
<script>

 if(Url_Seg1==="sports"){   $(".ad").css("background","white"); }else{ 
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1489467324804-0'); });

}
</script>
</div>
<!-- google_ad_section_end -->
</div>
</section>
<div class="story-view">
<div class="section-home-header clearfix noprint">
<ol class="breadcrumb">
<li class="breadcrumb-item"><a href="/1148-1148-hfsx23z/index.html">Home</a></li>
<li class="breadcrumb-item"><a href="/news/1056-1056-u6geog/index.html">News</a></li>
<li class="breadcrumb-item"><a href="/news/politics/1064-1064-4f88toz/index.html">Politics</a></li>
</ol>
</div>
<header>
<h2>Balala team should run Nairobi, MCAs now tell State</h2>
<p class="summary"><h6>Friday January 10 2020</h6><p class="noprint"><div class="social-networks noprint">
<a href="https://twitter.com/share?text=Nairobi MCAs ask State to help run capital city &amp;url=https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html&amp;via=dailynation" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/sharer.php?u=https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html" target="_blank"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<div class="mobileShow">
<a href="https://api.whatsapp.com/send?text=https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html" target="_blank"><i class="fa fa-whatsapp" aria-hidden="true"></i></a>
</div>
<a href="javascript:window.print()" target="_blank"><i class="fa fa-print" aria-hidden="true"></i></a>
<a href="/cdn-cgi/l/email-protection#e88689858da88d85898184c68b8785d79b9d8a828d8b9cd5a689819a878a81c8a5aba99bc8899b83c8bb9c899c8dc89c87c8808d8498c89a9d86c88b8998819c8984c88b819c91c8ce8a878c91d5a689819a878a81c8a5aba99bc8899b83c8bb9c899c8dc89c87c8808d8498c89a9d86c88b8998819c8984c88b819c91c8c5809c9c989bd2c7c79f9f9fc686899c818786c68b87c6838dc7868d9f9bc7988784819c818b9bc7a689819a878a81c5a5aba99bc59c809a879fc5bb87868387c59d868c8d9ac59c808dc58a9d9bc7d9d8dedcc5dddcd9dad0d0d8c5828781849a83c781868c8d90c6809c8584" target="_blank"><i class="fa fa-envelope-o" aria-hidden="true"></i></a>
</div></p>
<div>
<img class="photo_article" src="/image/view/-/5392778/highRes/2519553/-/maxw/600/-/11g6ofjz/-/sonko-pic.jpg" alt="Mike Sonko" />
<p id="photo_article_caption">
Nairobi Governor Mike Sonko at Milimani Law Courts on December 11, 2019. PHOTO | FILE | NATION MEDIA GROUP&nbsp;</p>
</div>
</header>
<article class="article">
<section class="article-sidebar">
<section class="summary">
<h4><b>In Summary</b></h4 >
<div><ul><li>The Regeneration Committee was formed in 2018 by President Uhuru Kenyatta to oversee key services in Nairobi County.</li><li>The ward representatives said the committee will work alongside members of the Nairobi County Executive to ensure effective service delivery to Nairobi residents. </li></ul></div></section>
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<!-- google_ad_section_start -->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/Z-DN-300x250-Politics-inContent-3', [300, 250], 'div-gpt-ad-1435750284803-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1435750284803-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1435750284803-0'); });
</script>
</div><!-- google_ad_section_end -->
</div>
</section>
</section>
<section class="body-copy">
<section class="author noprint">
<figure class="left">
<img src="/image/view/-/3818670/medRes/1298826/-/d3sieb/-/General+Image.jpg" width="50" alt="COLLINS OMULO" />
</figure>
<strong>By COLLINS OMULO</strong><br />
<a href="/authors/1959272-3302208-view-asAuthor-jt7kg1z/index.html"><span class="author-profile">More by this Author</span>
</a></section>
<div><p class="font-size--26">Nairobi MCAs are asking the national government to help in the running of the county government. The leaders have dropped plans to form an ad hoc committee to oversee the running of City Hall in the absence of Governor Mike Sonko.</p></div><div><p class="font-size--26"><strong>UNANIMOUSLY RESOLVED</strong></p></div><div><p class="font-size--26">They are now pushing for the revival of Nairobi Regeneration Committee to take over the running of county affairs.</p></div><div><p class="font-size--26">This comes after the MCAs agreed that the ad hoc committee had no legal backing and its constitution would have been challenged in court.</p></div><div><p class="font-size--26">The county legislators Thursday unanimously resolved to have the national government revamp the committee to take over the running of City Hall as long as Governor Sonko is still barred from office by the court until determination of a graft case facing him.</p></div><div><p class="font-size--26">The Regeneration Committee was formed in 2018 by President Uhuru Kenyatta to oversee key services in Nairobi County.</p></div><div id="relatedCoverage" class="article-related-coverage noprint">
<div class="related-coverage-header"><h4>Related Stories</h4></div>
<div class="related-coverage-body">
<ul>
<li>
<a href="https://www.nation.co.ke/news/politics/Battle-lines-drawn-as-Nairobi-MCAs-meet-over-Sonko-fate/1064-5411682-hvoa5pz/index.html">
<span class="relImage">
<figure>
<img class="lazy-loaded" src="/image/view/-/5397462/medRes/2531264/-/12ttvwnz/-/warpic.jpg" alt="Battle lines drawn as MCAs meet over Sonko fate">
</figure>
</span>
<span class="relText">Battle lines drawn as MCAs meet over Sonko fate</span>
</a>
</li>
<li>
<a href="https://www.nation.co.ke/oped/editorial/Why-Jubilee-stands-accused/440804-5412858-rvjm3vz/index.html">
<span class="relText">EDITORIAL: Why Jubilee stands accused</span>
</a>
</li>
<li>
<a href="https://www.nation.co.ke/news/Derailing-justice-claims-could-add-to-Sonko-troubles/1056-5410220-y9cg9s/index.html">
<span class="relImage">
<figure>
<img class="lazy-loaded" src="/image/view/-/5378188/medRes/2515500/-/bqsckh/-/SONPIC2.jpg" alt="Derailing justice claims could add to Sonko troubles">
</figure>
</span>
<span class="relText">Derailing justice claims could add to Sonko troubles</span>
</a>
</li>
</ul>
</div>
</div>
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<!-- google_ad_section_start -->
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="fluid" data-ad-layout-key="-gr+4o-z-4i+bl" data-ad-client="ca-pub-0846142691248784" data-ad-slot="8256349103"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script><!-- google_ad_section_end -->
</div>
</section>
<div><p class="font-size--26">It comprises national and county government leaders and is co-chaired by Tourism Cabinet Secretary Najib Balala and Governor Sonko and has been involved in clean-up of Nairobi River, rehabilitation of roads in Eastlands, among other services.</p></div><div><p class="font-size--26"><strong>IMMEDIATE CONCERNS</strong></p></div><div><p class="font-size--26">The ward representatives said the committee will work alongside members of the Nairobi County Executive to ensure effective service delivery to Nairobi residents. </p></div><div><p class="font-size--26">While reading the communication, Speaker Beatrice Elachi said the committee’s immediate areas of concern will be clearance of pending bills, water rationing and the garbage menace in the capital city.</p></div><div><p class="font-size--26">“I direct that the committee is revamped due to the good work it has done in order to proceed with its work together with county Executive to ensure effective service delivery to Nairobi residents,” said Ms Elachi.</p></div><div><p class="font-size--26">She was speaking while presiding over a Special Sitting called by the city MCAs to deliberate on county matters.</p></div><div><p class="font-size--26">Ms Elachi called on Nairobi Water and Sewerage Company to provide water rationing schedules to Nairobi residents and the Executive to partner with Kenya Urban Roads Authority in tarmacking and maintenance of county roads.</p></div><div><p class="font-size--26"><strong>LEGAL DUTY</strong></p></div><div><p class="font-size--26">On pending bills, the Speaker called on the Executive to ensure the bills are cleared, particularly for the youth, women and persons with disability, as well as develop a solid waste management programme.</p></div><div><p class="font-size--26">The MCAs agreed that indeed there is a crisis at the county government, calling for a committee to take over the running of the county government in the meantime.</p></div><div><p class="font-size--26">Minority Leader David Mberia said most departments at City Hall have stalled because of mass suspension of staff while Minority Whip Peter Imwatok said the county government has been on autopilot for months now.</p></div><div><p class="font-size--26">“We have a legal duty to ensure our people get services. Reassurances need actions as we cannot continue selling hopes without actions. The Regeneration Committee must now show the way forward,” said Majority Leader Charles Thuo.</p></div><div><p class="font-size--26"><strong>DWINDLING REVENUE</strong></p></div><div><p class="font-size--26">He was supported by Majority Whip June Ndegwa, who said: “I don't want people to think we are taking the functions of the governor but we just want to see that things are working.”</p></div><div><p class="font-size--26">Minority Deputy Whip and Kilimani MCA Moses Ogeto said services in Nairobi had stalled and called for the return of the committee.</p></div><div><p class="font-size--26">“Service delivery under this government has failed. The Regeneration Committee must come back. It had a good agenda for the county,” said Mr Ogeto.</p></div><div><p class="font-size--26">Embakasi MCA Michael Ogada complained of dwindling revenue collection, roads with potholes and lack of drugs in most county health facilities due to non-payment to the Kenya Medical Supplies Agency.</p></div><div><p class="font-size--26"><strong>BUDGET EXHAUSTED</strong></p></div><div><p><span class="font-size--26">“Garbage is all over with the waste collectors complaining they are not being paid, so they can't continue collecting the waste yet the Executive is saying their budget is almost exhausted. Where did the money go?” asked Mr Ogada.​</span><br /></p></div><p class="summary noprint"><div class="social-networks noprint">
<a href="https://twitter.com/share?text=Nairobi MCAs ask State to help run capital city &amp;url=https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html&amp;via=dailynation" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/sharer.php?u=https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html" target="_blank"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<div class="mobileShow">
<a href="https://api.whatsapp.com/send?text=https://www.nation.co.ke/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html" target="_blank"><i class="fa fa-whatsapp" aria-hidden="true"></i></a>
</div>
<a href="javascript:window.print()" target="_blank"><i class="fa fa-print" aria-hidden="true"></i></a>
<a href="/cdn-cgi/l/email-protection#244a454941644149454d480a474b491b5751464e414750196a454d564b464d04696765570445574f04775045504104504b044c4148540456514a044745544d50454804474d505d0402464b405d196a454d564b464d04696765570445574f04775045504104504b044c4148540456514a044745544d50454804474d505d04094c505054571e0b0b5353530a4a45504d4b4a0a474b0a4f410b4a4153570b544b484d504d47570b6a454d564b464d096967655709504c564b5309774b4a4f4b09514a40415609504c41094651570b1514121009111015161c1c14094e4b4d48564f0b4d4a40415c0a4c504948" target="_blank"><i class="fa fa-envelope-o" aria-hidden="true"></i></a>
</div></p>
</section>
<br clear="all">
<div class="noprint">
<div class="noprint">
<div id="taboola-below-article-thumbnails"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
							window._taboola = window._taboola || [];
							_taboola.push({
								mode: 'thumbnails-a',
								container: 'taboola-below-article-thumbnails',
								placement: 'Below Article Thumbnails',
								target_type: 'mix'
							});
						</script>
</div>
</div>
<section class="print-section big-blog noprint" id="headlines">
<header class="clearfix">
<div class="blog-header clearfix">
<h3>In the headlines</h3>
</div>
</header>
<article>
<div class="row">
<div class="five-eight column">
<div class="story-teaser medium-teaser">
<h3> <a href="/news/New-NHIF-rules-to-hit-voluntary-members/1056-5412898-11dmnsxz/index.html">New NHIF rules to hit voluntary members</a></h3>
<div class="">
<figure class="">
<a href="/news/New-NHIF-rules-to-hit-voluntary-members/1056-5412898-11dmnsxz/index.html">
<img class="lazy-loaded" src="/image/view/-/5205214/medRes/2401410/-/v77cld/-/ATWPIC.jpg" alt="New NHIF rules to hit voluntary members">
</a>
</figure>
<p>
Fund says move will boost the attainment of UHC and enhance member retention.</p>
</div>
</div>
</div>
<div class="three-eight column">
<div class="small-story-list">
<h5 class="small-story-list"><a href="/news/Experts-market-locusts-as-healthy-food/1056-5412862-tbso70/index.html">Experts market locusts as healthy food</a></h5>
<h5 class="small-story-list"><a href="/news/africa/Voodoo-makes-a-comeback-in-its-Benin-home/1066-5412944-pooabz/index.html">Voodoo makes a comeback in its Benin home - PHOTOS</a></h5>
<h5 class="small-story-list"><a href="/news/politics/Raila-starts-BBI-campaigns-in-Kisii/1064-5412876-10457sd/index.html">Raila starts BBI campaigns in Kisii</a></h5>
<h5 class="small-story-list"><a href="/news/world/Trudeau--Iranian-missile-brought-down-airliner/1068-5412914-sjw2po/index.html">Canadian PM: Iranian missile brought down airliner</a></h5>
<h5 class="small-story-list"><a href="/sports/Paul-Bitok-Mercy-Moim-speak-Malkia-Strikers-seal-Olympics-return/1090-5412710-13kg3xo/index.html">Bitok, Moim speak after Malkia Strikers seal Olympics return</a></h5>
<h5 class="small-story-list"><a href="/sports/motorsport/CS-Balala-Safari-Rally-will-market-our-tourist-sites/464918-5412456-hvm0j/index.html">CS Balala: Safari Rally will market our tourist sites</a></h5>
</div>
</div>
</div>
</article>
</section>
</article>
</div>
<script type="text/javascript">
	  /* CONFIGURATION START */
	  var _ain = {
		id: "1714",
		postid: "5412880",
		maincontent: "h2, #photo_article_caption, section.summary, section.body-copy",
		title: "Balala team should run Nairobi, MCAs now tell State",
		pubdate: "2020-01-10 06:00:00",		
		authors: "COLLINS OMULO",		    
		sections: "Politics",
		tags: "Nairobi Regeneration Committee, Special Sitting, Beatrice Elachi, ",
		comments: ""
	  };
	  /* CONFIGURATION END */
	  (function(d,s){var sf=d.createElement(s);sf.type='text/javascript';sf.async=!0;sf.src=(('https:'==d.location.protocol)?'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com':'http://t.contentinsights.com')+'/stf.js';var t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(sf,t)})(document,'script')
	</script>
<script>		
		var author = 'COLLINS OMULO';		
		ga('set', 'dimension1', author);
		var pubdate = '2020-01-10 06:00:00';
		ga('set', 'dimesion2', pubdate);
	</script>
<script>
	  dataLayer = [{
		'site': 'https://www.nation.co.ke',
		'section': 'Politics',
		//'subsection': 'business',
		'pageTitle': 'Balala team should run Nairobi, MCAs now tell State',
		//'pageCategory': 'money markets',
		'author': 'COLLINS OMULO',		
		'keywords': ['Nairobi Regeneration Committee',' Special Sitting',' Beatrice Elachi',' ']
	 }];
	</script>
</article>


<aside class="aside column noprint">
<div class="row">

<div class="sidebar-item">
<div class="ad">
<span>Advertisement</span>
<!-- google_ad_section_start -->
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/Z-dn-300x250-politicsins2', [300, 250], 'div-gpt-ad-1544079463159-0').addService(googletag.pubads());
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1544079463159-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1544079463159-0'); });
</script>
</div><!-- google_ad_section_end -->
</div>
</div>
<!-- google_ad_section_start -->
<div class="mailchimp-container"><div class="mp-logo"> <img src="https://cdn.nation.co.ke/mailchimp/dn-logo.png" alt="Daily Nation"></div><h2> NEVER MISS A STORY</h2><p> Get Breaking News Delivered to your Inbox</p><form action="https://nation.us16.list-manage.com/subscribe/post?u=0fd426a35325118486f65036d&amp;id=814d50c894" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate get-news" target="_blank" novalidate><div class="mp-field"><div class="textbox-with-icon"> <input type="email" class="textbox" id="mce-EMAIL" name="EMAIL" maxlength="100" placeholder="Email"></div><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_0fd426a35325118486f65036d_814d50c894" tabindex="-1" value=""></div></div><div id="error" style="color: #FF0000"></div><div id="success" style="color: #008000"></div><div class="mp-field last"> <button class="submit-btn" name="subscribe" id="mc-embedded-subscribe" type="submit">Subscribe</button></div></form><div class="alerts-title"><h2>News On The Go</h2></div><a href="https://www.facebook.com/messages/t/DailyNation" class="scribe-to-link facebook" target="_blank"><div class="scribe-to"><div class="scribe-icon"> <span class="bg-cl"></span> <svg viewBox="0 0 128 128" xml:space="preserve"><g><g id="Facebook_Messenger_1_"><rect clip-rule="evenodd" fill="none" fill-rule="evenodd" height="35" width="35" /><path clip-rule="evenodd" d="M70.36,79.802L54.062,62.42 L22.261,79.802l34.981-37.136l16.696,17.383l31.404-17.383L70.36,79.802z M64,0C28.654,0,0,26.531,0,59.259 c0,18.649,9.307,35.283,23.851,46.146V128l21.791-11.96c5.816,1.609,11.977,2.478,18.358,2.478c35.346,0,64-26.531,64-59.259 S99.346,0,64,0z" fill="#007FFF" fill-rule="evenodd" id="Facebook_Messenger" /></g></g></svg></div><div class="scribe-text-c"> <span>Facebook Messenger</span></div><div class="scribe-btn-o"> <span>Subscribe</span></div></div> </a> <a href="https://t.me/joinchat/AAAAAEFe-Usn27J-bxu6Dw" class="scribe-to-link telegram" target="_blank"><div class="scribe-to"><div class="scribe-icon"> <svg style="enable-background:new 0 0 512 512;" viewBox="0 0 512 512" xml:space="preserve"><style type="text/css">.st0{fill:url(#SVGID_1_)}.st1{fill:#FFF}.st2{fill:#D2E4F0}.st3{fill:#B5CFE4}</style><g><linearGradient gradientUnits="userSpaceOnUse" id="SVGID_1_" x1="256" x2="256" y1="0" y2="510.1322"><stop offset="0" style="stop-color:#41BCE7" /><stop offset="1" style="stop-color:#22A6DC" /></linearGradient><circle class="st0" cx="256" cy="256" r="256" /><g><path class="st1" d="M380.6,147.3l-45.7,230.5c0,0-6.4,16-24,8.3l-105.5-80.9L167,286.7l-64.6-21.7c0,0-9.9-3.5-10.9-11.2 c-1-7.7,11.2-11.8,11.2-11.8l256.8-100.7C359.5,141.2,380.6,131.9,380.6,147.3z" /><path class="st2" d="M197.2,375.2c0,0-3.1-0.3-6.9-12.4c-3.8-12.1-23.3-76.1-23.3-76.1l155.1-98.5c0,0,9-5.4,8.6,0 c0,0,1.6,1-3.2,5.4c-4.8,4.5-121.8,109.7-121.8,109.7" /><path class="st3" d="M245.8,336.2l-41.7,38.1c0,0-3.3,2.5-6.8,0.9l8-70.7" /></g></g></svg></div><div class="scribe-text-c"> <span>Telegram</span></div><div class="scribe-btn-o"> <span>Subscribe</span></div></div> </a></div><!-- google_ad_section_end -->


<div class="sidebar-item">
<div class="tab-header">
<div class="tab">
<span class="icon most-read-icon"></span>Latest News</div>
</div>
<div class="tab-body">

<li class="most-popular-item">
<a href="/news/Experts-market-locusts-as-healthy-food/1056-5412862-tbso70/index.html">
<span class="most-number">1</span>
<span class="most-headline"><span>News</span> Experts market locusts as healthy food</span>
</a>
</li>

<li class="most-popular-item">
<a href="/news/politics/Nairobi-MCAs-throw-Sonko-under-the-bus/1064-5412880-joilrk/index.html">
<span class="most-number">2</span>
<span class="most-headline"><span>Politics</span> Nairobi MCAs ask State to help run capital city </span>
</a>
</li>

<li class="most-popular-item">
<a href="/news/New-NHIF-rules-to-hit-voluntary-members/1056-5412898-11dmnsxz/index.html">
<span class="most-number">3</span>
<span class="most-headline"><span>News</span> New NHIF rules to hit voluntary members</span>
</a>
</li>

<li class="most-popular-item">
<a href="/news/africa/Voodoo-makes-a-comeback-in-its-Benin-home/1066-5412944-pooabz/index.html">
<span class="most-number">4</span>
<span class="most-headline"><span>Africa</span> Voodoo makes a comeback in its Benin home - PHOTOS</span>
</a>
</li>

<li class="most-popular-item">
<a href="/news/world/US-House-votes-to-curb-Trump-war-power-on-Iran/1068-5412940-6cpdnsz/index.html">
<span class="most-number">5</span>
<span class="most-headline"><span>World</span> US House votes to curb Trump war power on Iran</span>
</a>
</li>

<li class="most-popular-item">
<a href="/news/africa/Dozens-killed-by-heavy-rain-in-Angola/1066-5412932-117tt5az/index.html">
<span class="most-number">6</span>
<span class="most-headline"><span>Africa</span> Dozens killed by heavy rain in Angola</span>
</a>
</li>
</div>
</div>

<div class="sidebar-item">
<div class="ad">
<span>Advertisement</span>
<!-- google_ad_section_start -->
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/Z-Dn-300x250-politics1', [300, 250], 'div-gpt-ad-1544079699457-0').addService(googletag.pubads());
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1544079699457-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1544079699457-0'); });
</script>
</div><!-- google_ad_section_end -->
</div>
</div>

<section class="sidebar-item">
<header class="tab-header">
<div class="tab"><span class="icon gallery"></span>
LATEST NTV VIDEOS</div>
</header>
<article class="tab-body">
<div class="whole ntv-most-viewed">
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5411212-w2yb1yz/index.html"><img src="https://img.youtube.com/vi/LG4AlmgSEXM/mqdefault.jpg" alt="Road to Tokyo: Malkia Strikers beat Cameroon || Sports Wrap"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5411212-w2yb1yz/index.html">Road to Tokyo: Malkia Strikers beat Cameroon || Sports Wrap</a></p>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5411120-w2ybslz/index.html"><img src="https://img.youtube.com/vi/h8mlSv2Qy7s/mqdefault.jpg" alt="" You are not boarding": Miguna Miguna kicked out of plane in France"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5411120-w2ybslz/index.html">"You are not boarding": Miguna Miguna kicked out of plane in France</a></p>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5400284-w3lj37z/index.html"><img src="https://img.youtube.com/vi/5slyR299owU/mqdefault.jpg" alt="#Past10s: In the past ten years, budget, debt have risen significantly"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5400284-w3lj37z/index.html">#Past10s: In the past ten years, budget, debt have risen significantly</a></p>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5400282-w3lj39z/index.html"><img src="https://img.youtube.com/vi/7ljIsc_Alnk/mqdefault.jpg" alt="DPP proposes that traffic police officers should have body cameras"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5400282-w3lj39z/index.html">DPP proposes that traffic police officers should have body cameras</a></p>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5400274-w3lj43z/index.html"><img src="https://img.youtube.com/vi/yU_xq4zzrTY/mqdefault.jpg" alt="Michael Olunga answers critics questioning his motivation for football"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5400274-w3lj43z/index.html">Michael Olunga answers critics questioning his motivation for football</a></p>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5400262-w3lj51z/index.html"><img src="https://img.youtube.com/vi/IZGq1nSUwx0/mqdefault.jpg" alt="Siaya: Funeral service for Court of Appeal Judge James Otieno Odek underway"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5400262-w3lj51z/index.html">Siaya: Funeral service for Court of Appeal Judge James Otieno Odek underway</a></p>
</div>
</div>
</div>
</article>

</section>
<!-- google_ad_section_start -->
<div class="nfmPlayer">
<audio controls name="media"><source src="https://stream.radiojar.com/3by7s8eg65quv" type="audio/mpeg"></audio>
</div><!-- google_ad_section_end -->
<div class="clearfix"></div>
<div class="tab-header" style="margin-top:1em;">
<div class="tab"><span class="icon most-read-icon"></span>Latest Nairobi News</div>
</div>
<iframe src="https://nairobinews.nation.co.ke/dn-widget/" height="600" width="355" frameborder="0" scrolling="auto" id="nn-iframe"> </iframe>
<!-- google_ad_section_start -->
<script>

/*  window.googletag = window.googletag || {cmd: []};

  googletag.cmd.push(function() {

    googletag.defineSlot('/1010816/Z-DN-article-rightpanel', [300, 250], 'div-gpt-ad-1564563127559-0').addService(googletag.pubads());

    googletag.pubads().enableSingleRequest();

    googletag.enableServices();

  }) ; */

</script>​ 

  <script>

    /*googletag.cmd.push(function() { googletag.display('div-gpt-ad-1564563127559-0'); });*/

  </script>

<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-0846142691248784" data-ad-slot="7537505707"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script><!-- google_ad_section_end -->
</div>
</aside>
</div>
</div>
</section>
</section>
</article>
<footer class="footer section">
<div class="container">
<div class="row">
<div class="main column">
</div>
<div class="aside column"></div>
</div>
</div>
</footer>
<footer class="wrapper page-footer" id="page-footer">

<div class="menu-holder menu-holder-footer noprint">
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/news/1056-1056-u6geog/index.html" title="News"><h3 class="footer-section-heading">News</h3></a>
</header>
<a href="https://www.nation.co.ke/news/politics/1064-1064-4f88toz/index.html" title="Politics">Politics</a>
<a href="https://www.nation.co.ke/news/africa/1066-1066-oo1nedz/index.html" title="Africa">Africa</a>
<a href="https://www.nation.co.ke/news/world/1068-1068-y0kl4cz/index.html" title="World">World</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/business/996-996-x0uutpz/index.html" title="Business"><h3 class="footer-section-heading">Business</h3></a>
</header>
<a href="https://www.nation.co.ke/business/seedsofgold/2301238-2301238-e2g5gz/index.html" title="Seeds of Gold">Seeds of Gold</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/counties/1107872-1107872-44rd16z/index.html" title="Counties"><h3 class="footer-section-heading">Counties</h3></a>
</header>
<a href="https://www.nation.co.ke/counties/coast/3347800-3347800-ey6rn8z/index.html" title="Coast">Coast</a>
<a href="https://www.nation.co.ke/counties/northern-region/3347734-3347734-155vfigz/index.html" title="Northern">Northern</a>
<a href="https://www.nation.co.ke/counties/eastern-region/3347810-3347810-2501vq/index.html" title="Eastern">Eastern</a>
<a href="https://www.nation.co.ke/counties/mtkenya/3317830-3317830-7p8g5w/index.html" title="Mt Kenya ">Mt Kenya </a>
<a href="https://www.nation.co.ke/counties/north-rift/3347778-3347778-aga2m3z/index.html" title="North Rift">North Rift</a>
<a href="https://www.nation.co.ke/counties/south-rift/3347782-3347782-rtpd5y/index.html" title="South Rift">South Rift</a>
<a href="https://www.nation.co.ke/counties/western-region/3347786-3347786-nvg1d5/index.html" title="Western">Western</a>
<a href="https://www.nation.co.ke/counties/nyanza-kisii-region/3347796-3347796-unywdg/index.html" title="Nyanza-Kisii">Nyanza-Kisii</a>
<a href="https://www.nation.co.ke/counties/nairobi/1954174-1954174-swx4nez/index.html" title="Nairobi">Nairobi</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/sports/1090-1090-iqcgwe/index.html" title="Sports"><h3 class="footer-section-heading">Sports</h3></a>
</header>
<a href="https://www.nation.co.ke/sports/football/1102-1102-5p3gunz/index.html" title="Football">Football</a>
<a href="https://www.nation.co.ke/sports/athletics/1100-1100-g06rtez/index.html" title="Athletics">Athletics</a>
<a href="https://www.nation.co.ke/sports/rugby/1106-1106-g0i5l0z/index.html" title="Rugby">Rugby</a>
<a href="https://www.nation.co.ke/sports/golf/1104-1104-hjqyif/index.html" title="Golf">Golf</a>
<a href="https://www.nation.co.ke/sports/othersports/1951306-1951306-fy284lz/index.html" title="Others">Others</a>
<a href="https://www.nation.co.ke/sports/talkup/441392-441392-wkoe7h/index.html" title="TalkUp">TalkUp</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/oped/1192-1192-110kbth/index.html" title="Blogs & Opinion"><h3 class="footer-section-heading">Blogs &amp; Opinion</h3></a>
</header>
<a href="https://www.nation.co.ke/oped/blogs/620-620-obkqwq/index.html" title="Blogs">Blogs</a>
<a href="https://www.nation.co.ke/oped/opinion/440808-440808-h8w00fz/index.html" title="Commentaries">Commentaries</a>
<a href="https://www.nation.co.ke/oped/editorial/440804-440804-id1ldp/index.html" title="Editorial">Editorial</a>
<a href="https://www.nation.co.ke/oped/cartoon/454986-454986-14tce6c/index.html" title="Cartoons">Cartoons</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/lifestyle/1190-1190-5p56avz/index.html" title="Life & Style"><h3 class="footer-section-heading">Life &amp; Style</h3></a>
</header>
<a href="https://www.nation.co.ke/lifestyle/artculture/1954194-1954194-7hp6o1/index.html" title="Art & Culture">Art &amp; Culture</a>
<a href="https://www.nation.co.ke/lifestyle/family/1954198-1954198-jeojfi/index.html" title="Family">Family</a>
<a href="https://www.nation.co.ke/lifestyle/health/1954202-1954202-rynt7v/index.html" title="Health">Health</a>
<a href="https://www.nation.co.ke/lifestyle/showbiz/1950810-1950810-25qq0az/index.html" title="Showbiz">Showbiz</a>
<a href="https://www.nation.co.ke/lifestyle/travel/1950822-1950822-ry3yf4/index.html" title="Travel">Travel</a>
<a href="https://www.nation.co.ke/lifestyle/women/1950830-1950830-b0uq99z/index.html" title="Women & Style">Women &amp; Style</a>
<a href="https://www.nation.co.ke/lifestyle/magazines/2439396-2439396-u46yvl/index.html" title="Magazines">Magazines</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/video/1951480-1951480-1072vroz/index.html" title="Videos"><h3 class="footer-section-heading">Videos</h3></a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/photo/1951220-1951220-df7whxz/index.html" title="Photos"><h3 class="footer-section-heading">Photos</h3></a>
</header>
</nav>
</div>
<footer id="dnFooter">
<div class="dnFooter-row noprint">
<div class="dnFooter-col-sm-3">
<h5></h5>
<form action="https://nation.us16.list-manage.com/subscribe/post?u=0fd426a35325118486f65036d&amp;id=814d50c894" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate get-news" target="_blank" novalidate>
<div class="mp-field">
<div class="textbox-with-icon">
<input type="email" class="textbox" id="mce-EMAIL" name="EMAIL" maxlength="100" placeholder="Email">
</div>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_0fd426a35325118486f65036d_814d50c894" tabindex="-1" value=""></div>
</div>
<div id="error" style="color: #FF0000"></div>
<div id="success" style="color: #008000"></div>
<div class="mp-field last">
<button class="submit-btn" name="subscribe" id="mc-embedded-subscribe" type="submit">Subscribe</button>
</div>
</form>
<h5></h5>
<a href="https://www.nation.co.ke"><img src="https://www.nation.co.ke/nationmedia/css/icons/dailynation/dnLogoFooter.png" alt="Daily Nation" class="logo" /></a>
</div>
<div class="dnFooter-col-sm-2">
<h5>Apps</h5>
<ul>
<li><a href='https://play.google.com/store/apps/developer?id=Nation%20Media%20Group&hl=en&pcampaignid=MKT-Other-global-all-co-prtnr-py-PartBadge-Mar2515-1' target='_blank'><img alt='Play Store' src='https://www.nation.co.ke/nationmedia/css/icons/dailynation/google-play-badge.png' /></a></li><br>
<li><a href="https://itunes.apple.com/us/developer/nation-media-group-ltd/id771736086" target="_blank"><img src="https://www.nation.co.ke/nationmedia/css/icons/dailynation/appStoreIcon.svg" alt="App Store" class="logo" /></a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>Information</h5>
<ul>
<li><a href="https://www.nation.co.ke/meta/1194-1174-byky0p/index.html" title="Contact Us">Contact Us</a></li><li><a href="https://www.nation.co.ke/meta/1194-1184-byky1l/index.html" title="FAQ">FAQ</a></li><li><a href="http://epaper.nationmedia.com" title="E-papers">E-papers</a></li><li><a href="https://www.nation.co.ke/meta/1194-1182-byky1j/index.html" title="Privacy Policy">Privacy Policy</a></li><li><a href="https://www.nation.co.ke/meta/1194-1186-byky1n/index.html" title="Terms">Terms</a></li></ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>NMG Sites</h5>
<ul>
<li><a href="https://pishi.co.ke/" target="_blank" title="Pishi">Pishi</a></li><li><a href="http://lit360.africa" target="_blank" title="Lit360">Lit360</a></li><li><a href="http://transitions.nation.co.ke/" target="_blank" title="Nation Transitions">Nation Transitions</a></li><li><a href="https://nairobinews.nation.co.ke" target="_blank" title="Nairobi News">Nairobi News</a></li><li><a href="http://www.businessdailyafrica.com/" target="_blank" title="Business Daily">Business Daily</a></li><li><a href="https://ntv.nation.co.ke" target="_blank" title="NTV">NTV</a></li><li><a href="http://www.ntv.co.ug" target="_blank" title="NTV Uganda">NTV Uganda</a></li><li><a href="http://www.monitor.co.ug/" target="_blank" title="Daily Monitor">Daily Monitor</a></li><li><a href="http://www.thecitizen.co.tz/" target="_blank" title="The Citizen">The Citizen</a></li><li><a href="http://www.mwananchi.co.tz/" target="_blank" title="Mwananchi">Mwananchi</a></li><li><a href="http://www.mwanaspoti.co.tz" target="_blank" title="Mwanaspoti">Mwanaspoti</a></li><li><a href="http://taifaleo.nation.co.ke/" target="_blank" title="Taifa Leo">Taifa Leo</a></li><li><a href="http://www.swahilihub.com/" target="_blank" title="Swahili Hub">Swahili Hub</a></li><li><a href="http://www.theeastafrican.co.ke" target="_blank" title="The EastAfrican">The EastAfrican</a></li><li><a href="http://www.nationmedia.com" target="_blank" title="Nation Media Group">Nation Media Group</a></li></ul>
</div>
<div class="dnFooter-col-sm-3">
<h5>Follow us</h5>
<div class="social-networks">
<a href="https://twitter.com/dailynation" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/DailyNation/" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.instagram.com/dailynation/" target="_blank"><i class="fa fa-instagram" aria-hidden="true"></i></a>
<a href="https://www.youtube.com/user/DNKenya" target="_blank"><i class="fa fa-youtube" aria-hidden="true"></i></a>
<a href="/news/politics/1064-1064-view-asFeed-gogm2d/index.xml"><i class="fa fa-rss-square" aria-hidden="true"></i></a></div>
<h1 style="font-size: 0px; margin: 0px;">Daily Nation</h1>
</div>
</div>
</footer></footer><script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>	
	
			_sf_async_config.path = '/5412880';
		_sf_async_config.sections = 'news,news - politics';_sf_async_config.authors = 'collins omulo';
	_sf_async_config.autoDetect=false;
    /** CONFIGURATION END **/
    (function(){
        function loadChartbeat() {
            var e = document.createElement('script');
            var n = document.getElementsByTagName('script')[0];
            e.type = 'text/javascript';
            e.async = true;
            e.src = '//static.chartbeat.com/js/chartbeat_video.js';
            n.parentNode.insertBefore(e, n);
        }
		var _cbv = window._cbv || (window._cbv = []);_cbv.push(['autoDetectYouTubeIframes']);
        loadChartbeat();
    })();
</script>
<script src="/code/view/DailyNation/-/3797660/-/11l9hi4/-/jquery-3.1.1.min.js.js"></script>
<script>window.jQuery || document.write('<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.0/jquery.min.js"><\/script>')</script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/3797660/-/11l9hi4/-/jquery-3.1.1.min.js.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/2151136/-/gcrtsk/-/main_final.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/2456274/-/i04jhl/-/globalvideo.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/1949300/-/3sj01m/-/lazyload.min.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/1954386/-/3t22jc/-/jquery.social.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/2627434/-/j1g52o/-/jquery-cross.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/2627436/-/j1g52q/-/sharebutton.min.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/3783924/-/11kk8l2/-/jquery-migrate.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/3783912/-/11kk8k4/-/camera.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/3783926/-/11kk8l4/-/jquery-owl.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/4124544/-/vn95vgz/-/ticker-v1.0.1.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/4125928/-/vn8dh4z/-/tabcontent.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/4131258/-/vmora1z/-/showMore.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/5371732/-/dkn8jwz/-/vendor.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/5371728/-/dkn8kmz/-/app.js"></script>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
<script src="/code/view/DailyNation/-/3783932/-/11kk8lv/-/electionsScript-v1.0.6.js"></script>
<script src="https://secure.widget.cloud.opta.net/v3/v3.opta-widgets.js"></script>
<script>var opta_settings={subscription_id:'11b2b9ec8f805a62b48ae6b59caf131a',language:'en_GB',timezone:'Africa/Nairobi'};</script>
<script type="text/javascript">$(".fifaShowHide").click(function(){$(".fifaShowHide span").html($(".fifaShowHide span").html()=='Hide'?'Show':'Hide')});</script>
<meta name="google-site-verification" content="bpM21xTzIpu_rdMgMeiN9tKlX_lDX_N44hD_YFzbT1s" />
<meta property="fb:pages" content="105983259496" />
<script>window.fbAsyncInit=function(){FB.init({appId:'174023979648743',xfbml:!0,version:'v2.5'})};(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/sdk.js";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'));</script>
<script type="text/javascript">window._taboola=window._taboola||[];_taboola.push({article:'auto'});!function(e,f,u,i){if(!document.getElementById(i)){e.async=1;e.src=u;e.id=i;f.parentNode.insertBefore(e,f)}}(document.createElement('script'),document.getElementsByTagName('script')[0],'//cdn.taboola.com/libtrc/nationmediagroup-dailynation/loader.js','tb_loader_script');</script>
<script type="text/javascript">$(".right-corder-container-button").hover(function(){var aud=$('audio')[0];$(".long-text").addClass("show-long-text");if(aud.paused){aud.play();$(".paused").hide();$(".live").show()}else{aud.pause();$(".paused").show();$(".live").hide()}},function(){$(".long-text").removeClass("show-long-text");if(aud.paused){aud.play();$(".paused").hide();$(".live").show()}else{aud.pause();$(".paused").show();$(".live").hide()}});</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>var domainpaths=window.location.pathname.split('/');if(domainpaths[1]=="brandbook"||domainpaths.length<4||domainpaths[1]=="supplements"||domainpaths[1]=="nationprime"){}else{    (adsbygoogle=window.adsbygoogle||[]).push({          google_ad_client:"ca-pub-0846142691248784",          enable_page_level_ads:!0});    }</script>

<script type="text/javascript">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</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineOutOfPageSlot('/1010816/Z-DN-RoadBlock', 'div-gpt-ad-1546077479768-0').addService(googletag.pubads());
    googletag.enableServices();
  });
</script>
<script>var domainpaths=window.location.pathname.split('/');if(domainpaths[1]=="brandbook"||domainpaths[1]=="supplements"||domainpaths[1]=="nationprime"){}else{    (adsbygoogle=window.adsbygoogle||[]).push({          google_ad_client:"ca-pub-0846142691248784",          enable_page_level_ads:!0});    }</script>

<div id='div-gpt-ad-1546077479768-0'>
<script>var domainpaths=window.location.pathname.split('/');if(domainpaths[1]=="brandbook"||domainpaths[1]=="supplements"||domainpaths[1]=="nationprime"){}else{ googletag.cmd.push(function() { googletag.display('div-gpt-ad-1546077479768-0'); }); }</script>
</div></body>
</html>