<!DOCTYPE html>
<!--[if lt IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 8]><html lang="en" class="no-js lt-ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 9]><html lang="en" class="no-js ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#" ><![endif]-->
<!--[if gt IE 8]><!--><html lang="en" class="no-js" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><!--<![endif]-->
<head>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1030601-4"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'UA-1030601-4',{  
  'custom_map': {'dimension2': 'pubdate'}
});
</script>

<script type="text/javascript">_atrk_opts={atrk_acct:"7CIsk1acBb00OC",domain:"nation.co.ke",dynamic:!0};(function(){var as=document.createElement('script');as.type='text/javascript';as.async=!0;as.src="https://certify-js.alexametrics.com/atrk.js";var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as,s)})();</script><noscript><img src="https://certify.alexametrics.com/atrk.gif?account=7CIsk1acBb00OC" style="display:none" height="1" width="1" alt="alexa"/></noscript>

<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<meta name="google-site-verification" content="bpM21xTzIpu_rdMgMeiN9tKlX_lDX_N44hD_YFzbT1s" /><meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="msvalidate.01" content="EAEA2E15D93BC2979D58720786AF2DDB" />
<meta name="alexaVerifyID" content="e8s521zf2lW3kSQNwGY2XMME5No" />
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" /><meta name="viewport" content="width=device-width,initial-scale=1">
<meta name="robots" content="index, follow">
<script>gtag('event', 'pubdate_dimension', {'pubdate': "2019-08-12 02:10:49"});</script>
<title>Returning Wazito eager to hit the ground running - Daily Nation</title>
<meta name="description" content="&#034; Our target is to compete in the league and I think we are ready,&#034; said Okumbi." />
<meta name="keywords" content="JEFF KINYANJUI, Kenyan Premier League, Wazito, Stanley Okumbi, Solomon Alubala, Musa Masika," /><meta property="fb:app_id" content="174023979648743" />
<meta property="fb:pages" content="105983259496" />
<meta property="og:site_name" content="Daily Nation" />
<meta property="og:type" content="article" /><meta property="og:title" content="Returning Wazito eager to hit the ground running" />
<meta property="og:url" content="https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html" />
<meta property="og:description" content="&#034; Our target is to compete in the league and I think we are ready,&#034; said Okumbi." />
<meta property="og:locale" content="en_UK" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2019-08-12 02:10:49" />
<meta property="og:article:modified_time" content="2019-08-11 18:05:02" />
<meta property="og:image" content="https://www.nation.co.ke/image/view/-/5232028/medRes/2418131/-/sd3mwz/-/oku_pix.jpg" />
<meta property="og:image:width" content="425" />
<meta property="og:image:height" content="262" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@dailynation" />
<meta name="twitter:title" content="Returning Wazito eager to hit the ground running" />
<meta name="twitter:description" content="&#034; Our target is to compete in the league and I think we are ready,&#034; said Okumbi." />
<meta name="twitter:image" content="https://www.nation.co.ke/image/view/-/5232028/medRes/2418131/-/sd3mwz/-/oku_pix.jpg" />
<meta name="twitter:url" content="https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html" />
<script type="application/ld+json">{"@context": "http:\/\/schema.org","@type": "NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.nation.co.ke\/sports\/football\/Returning-Wazito-eager-to-hit-the-ground-running\/1102-5232024-rfxaucz\/index.html"},"headline": "Returning Wazito eager to hit the ground running","alternativeHeadline": "Returning Wazito eager to hit the ground running","image": {"@type": "ImageObject","url": "http:\/\/www.nation.co.ke\/image\/view\/-\/5232028\/medRes\/2418131\/-\/sd3mwz\/-\/oku_pix.jpg","height": 424,"width": 696},"datePublished": "2019-08-12 02:10:49","dateModified": "2019-08-11 18:05:02","author": {"@type": "Person","name": ["JEFF KINYANJUI"]},"publisher": {"@type": "Organization","name": "Daily Nation","logo": {"@type": "ImageObject","url": "http:\/\/www.nation.co.ke\/nationmedia\/css\/icons\/dnmobile\/dnlogo.png","width": 40,"height": 29}},"description": "&#034; Our target is to compete in the league and I think we are ready,&#034; said Okumbi."}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[[{"@type":"ListItem","position":1, "item":{"@id":"http:\/\/www.nation.co.ke","name":"Home"}},{"@type":"ListItem","position":2, "item":{"@id":"http:\/\/www.nation.co.ke\/sports\/1090-1090-iqcgwe\/index.html","name":"Sports"}},{"@type":"ListItem","position":3, "item":{"@id":"http:\/\/www.nation.co.ke\/sports\/football\/1102-1102-5p3gunz\/index.html","name":"Football"}}]]}</script><link rel="canonical" href="https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html" />
<link rel="amphtml" href="https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-view-asAMP-114hpci/index.html"><link rel="publisher" href="https://plus.google.com/117103205968039363033" /><link href="https://www.nation.co.ke/nationmedia/css/icons/dnmobile/apple-touch-icon.png" />
<link rel="apple-touch-icon" sizes="120x120" href="https://www.nation.co.ke/nationmedia/css/icons/dnmobile/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon" sizes="144x144" href="https://www.nation.co.ke/nationmedia/css/icons/dnmobile/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon" sizes="152x152" href="https://www.nation.co.ke/nationmedia/css/icons/dnmobile/apple-touch-icon-152x152.png" />
<link rel="stylesheet" href="https://www.nation.co.ke/nationmedia/css/fonts/fonts.css" type="text/css" media="screen" />
<link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet">
<link rel="stylesheet" href="https://secure.widget.cloud.opta.net/v3/css/v3.core.opta-widgets.css">
<link rel="stylesheet" href="https://secure.widget.cloud.opta.net/v3/css/v3.football.opta-widgets.css">
<link rel="shortcut icon" href="https://www.nation.co.ke/favicon.ico" type="image/x-icon" /><script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<script type="text/javascript" src="/code/view/DailyNation/-/1949308/-/3sj01u/-/modernizr-2.6.2.min.js" async></script>
<script src="/code/view/DailyNation/-/3797660/-/11l9hi4/-/jquery-3.1.1.min.js.js" async></script>
<script>if (!window.jQuery) { document.write('<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.0/jquery.min.js" async><\/script>');}</script>
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/1949856/-/3sj43i/-/normalize.min.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/4100284/-/vok37lz/-/main-dn-styles-v1.6.7.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/3783938/-/11kk8m2/-/election-css-v1.0.3.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/3783936/-/11kk8m0/-/camera-css.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/3783940/-/11kk8mp/-/owl-carousel.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/4239968/-/v3gbgtz/-/latestPopup.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/4107482/-/vof6ejz/-/vidStyle-v1.1.2.css" />
<link rel="stylesheet" type="text/css" href="/code/view/DailyNation/-/4221316/-/v48jqqz/-/GoogleSearchKe.css" />
<link rel="stylesheet" href="/code/view/DailyNation/-/416/-/8re5q6z/-/print.css" type="text/css" media="print"><script type="text/javascript">
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63208; // ACCOUNT NUMBER
  _sf_async_config.domain = 'nation.co.ke'; // DOMAIN
  _sf_async_config.flickerControl = false;
  
		_sf_async_config.useCanonical = false;
		_sf_async_config.useCanonicalDomain = false;
	  
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script></head>
<body>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<script src="https://cdn.nation.co.ke/dmp/bluekai-dfp-header-integration.js"></script><header class="navbar full-width noprint">
<nav class="container">
<a href="/1148-1148-hfsx23z/index.html" class="logo"></a>

<ul id="panel">
<li>
<a href="/news/1056-1056-u6geog/index.html">News</a></li>
<li>
<a href="/business/996-996-x0uutpz/index.html">Business</a></li>
<li>
<a href="/counties/1107872-1107872-44rd16z/index.html">Counties</a></li>
<li>
<a href="/sports/1090-1090-iqcgwe/index.html">Sports</a></li>
<li>
<a href="/oped/1192-1192-110kbth/index.html">Blogs &amp; Opinion</a></li>
<li>
<a href="/lifestyle/1190-1190-5p56avz/index.html">Life &amp; Style</a></li>
<li>
<a href="/video/1951480-1951480-1072vroz/index.html">Videos</a></li>
<li>
<a href="/photo/1951220-1951220-df7whxz/index.html">Photos</a></li>
</ul>

<ul>
<li>
<a href="/news/1056-1056-u6geog/index.html">News</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/news/politics/1064-1064-4f88toz/index.html">Politics</a><a href="/news/africa/1066-1066-oo1nedz/index.html">Africa</a><a href="/news/world/1068-1068-y0kl4cz/index.html">World</a></div>
<div class="main column">
<h4>Latest News</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/news/Matiangi-renews-drug-war-after-Bamburi-attacks/1056-5232044-13ptjl2z/index.html"><img src="/image/view/-/5232060/lowRes/2418154/-/gwgypg/-/matpic.jpg" alt="Interior Cabinet Secretary Fred Matiang’i, during a press" />
</a></figure>
<a href="/news/Matiangi-renews-drug-war-after-Bamburi-attacks/1056-5232044-13ptjl2z/index.html">Matiang&#039;i renews drug war after Bamburi attacks</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/news/Prison-bosses-moved-in-reshuffle/1056-5231428-138aybjz/index.html"><img src="/image/view/-/5231438/lowRes/2417737/-/yfhnnjz/-/prison-pic.jpg" alt="Correctional Services PS Zainab Hussein who on August 11, 2019 gave" />
</a></figure>
<a href="/news/Prison-bosses-moved-in-reshuffle/1056-5231428-138aybjz/index.html">Reshuffle as prison breaks taint police image</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/news/politics/Meru-leaders-back-William-Ruto-2022-bid/1064-5231970-rmbhc8z/index.html"><img src="/image/view/-/5232046/lowRes/2418148/-/b5c0bbz/-/RUTO-IMENTI.jpg" alt="Catholic priests pray for Deputy President William Ruto at St" />
</a></figure>
<a href="/news/politics/Meru-leaders-back-William-Ruto-2022-bid/1064-5231970-rmbhc8z/index.html">Meru leaders back Ruto&#039;s 2022 bid</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/news/politics/Let-us-support-BBI--Maina-Kamanda-urges-leaders/1064-5231922-bka6jc/index.html"><img src="/image/view/-/5231932/lowRes/2418050/-/appdfd/-/Kamanda1.jpg" alt="Nominated MP Maina Kamanda. He has urged leaders to support the" />
</a></figure>
<a href="/news/politics/Let-us-support-BBI--Maina-Kamanda-urges-leaders/1064-5231922-bka6jc/index.html">Kamanda slams leaders opposed to BBI</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/business/996-996-x0uutpz/index.html">Business</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/business/seedsofgold/2301238-2301238-e2g5gz/index.html">Seeds of Gold</a></div>
<div class="main column">
<h4>Latest Business</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/business/Kenya-Forest-Service-earns-Sh2-7bn-from-plantations/996-5231640-tkm1oy/index.html"><img src="/image/view/-/5231642/lowRes/2417840/-/bnpr2j/-/FOREST.jpg" alt="Kenya Forest Service officers inspect cedar posts that were" />
</a></figure>
<a href="/business/Kenya-Forest-Service-earns-Sh2-7bn-from-plantations/996-5231640-tkm1oy/index.html">Kenya Forest Service earns Sh2.7bn from plantations</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/business/Security-firms-race-to-comply-with-law/996-5231644-bufnafz/index.html"><img src="/image/view/-/5231646/lowRes/2417842/-/r748ahz/-/anda.jpg" alt="Kenya National Private Security Workers Union secretary-general" />
</a></figure>
<a href="/business/Security-firms-race-to-comply-with-law/996-5231644-bufnafz/index.html">Security firms race to comply with law ahead of deadline</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/business/Rwanda-tea-price-higher-than-Kenya-s-at-auction/996-5231614-logdvm/index.html"><img src="/image/view/-/5231616/lowRes/2417825/-/mphaevz/-/tea.jpg" alt="Kenya accounts for three quarter of the produce traded at the" />
</a></figure>
<a href="/business/Rwanda-tea-price-higher-than-Kenya-s-at-auction/996-5231614-logdvm/index.html">Rwanda tea price higher than Kenya’s at auction</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/business/seedsofgold/Cow-that-went-to-the-grave-with-top-secret/2301238-5230042-j8sr78z/index.html"><img src="/image/view/-/5230046/lowRes/2416963/-/l041x4/-/vet+img.jpg" alt="Dairy cattle feed in a farm. Most farm animal diseases are" />
</a></figure>
<a href="/business/seedsofgold/Cow-that-went-to-the-grave-with-top-secret/2301238-5230042-j8sr78z/index.html">Vet on Call: Cow that went to the grave with top secret</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/counties/1107872-1107872-44rd16z/index.html">Counties</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/counties/coast/3347800-3347800-ey6rn8z/index.html">Coast</a><a href="/counties/northern-region/3347734-3347734-155vfigz/index.html">Northern</a><a href="/counties/eastern-region/3347810-3347810-2501vq/index.html">Eastern</a><a href="/counties/mtkenya/3317830-3317830-7p8g5w/index.html">Mt Kenya </a><a href="/counties/north-rift/3347778-3347778-aga2m3z/index.html">North Rift</a><a href="/counties/south-rift/3347782-3347782-rtpd5y/index.html">South Rift</a><a href="/counties/western-region/3347786-3347786-nvg1d5/index.html">Western</a><a href="/counties/nyanza-kisii-region/3347796-3347796-unywdg/index.html">Nyanza-Kisii</a><a href="/counties/nairobi/1954174-1954174-swx4nez/index.html">Nairobi</a></div>
<div class="main column">
<h4>Latest Counties</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/counties/nakuru/Three-people-killed-in-Kikopey-accident/1183314-5232018-x4fy3rz/index.html"><img src="/image/view/-/5232026/lowRes/2418124/-/j3405f/-/PSV+Pic.jpg" alt="The wreckage of a matatu involved in a road accident at Kikopey" />
</a></figure>
<a href="/counties/nakuru/Three-people-killed-in-Kikopey-accident/1183314-5232018-x4fy3rz/index.html">Three killed in Kikopey crash</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/counties/Crisis-as-strike-looms-in-15-counties/1107872-5231948-h4c8nqz/index.html"><img src="/image/view/-/5231950/lowRes/2418066/-/2alunz/-/Nrb+staff.jpg" alt="Nairobi Governor Mike Sonko (not pictured) addresses county staff" />
</a></figure>
<a href="/counties/Crisis-as-strike-looms-in-15-counties/1107872-5231948-h4c8nqz/index.html">Crisis as strike looms in 15 counties</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/counties/homa-bay/Fire-destroys-Homa-Bay-County-Commissioner-residence/3444904-5232000-crimmez/index.html"><img src="/image/view/-/5232002/lowRes/2418106/-/6fau94/-/HSE.jpg" alt="Fire consumes Homa Bay County Commissioner Herman Shambi&#039;s" />
</a></figure>
<a href="/counties/homa-bay/Fire-destroys-Homa-Bay-County-Commissioner-residence/3444904-5232000-crimmez/index.html">Fire destroys Homa Bay County Commissioner&#039;s residence</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/counties/nyandarua/Nyandarua-executive-Kariuki-Mbataru-fights-impeachment-/3444764-5231846-c3uj31z/index.html"><img src="/image/view/-/5231892/lowRes/2418020/-/kqvt4n/-/nya-pic.jpg" alt="Nyandarua Speaker Wahome Ndegwa in a past assembly session. A" />
</a></figure>
<a href="/counties/nyandarua/Nyandarua-executive-Kariuki-Mbataru-fights-impeachment-/3444764-5231846-c3uj31z/index.html">Nyandarua executive fights impeachment </a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/sports/1090-1090-iqcgwe/index.html">Sports</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/sports/football/1102-1102-5p3gunz/index.html">Football</a><a href="/sports/athletics/1100-1100-g06rtez/index.html">Athletics</a><a href="/sports/rugby/1106-1106-g0i5l0z/index.html">Rugby</a><a href="/sports/golf/1104-1104-hjqyif/index.html">Golf</a><a href="/sports/othersports/1951306-1951306-fy284lz/index.html">Others</a><a href="/sports/talkup/441392-441392-wkoe7h/index.html">TalkUp</a></div>
<div class="main column">
<h4>Latest Sports</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/sports/football/Emery-impressed-despite-Arsenal-slim-win-Newcastle/1102-5232094-10pfp2dz/index.html"><img src="/image/view/-/5232106/lowRes/2418185/-/uc4o7v/-/emery_pix.jpg" alt="Arsenal&#039;s Spanish head coach Unai Emery gestures on the touchline" />
</a></figure>
<a href="/sports/football/Emery-impressed-despite-Arsenal-slim-win-Newcastle/1102-5232094-10pfp2dz/index.html">Emery impressed despite Arsenal&#039;s slim win</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/sports/Cairo-trip-split-Malkia-curious-case-missing-passport-/1090-5232068-e61xcf/index.html"><img src="/image/view/-/5232080/lowRes/2418160/-/day0rez/-/sike_pix.jpg" alt="Malkia Strikers players celebrate a point during the" />
</a></figure>
<a href="/sports/Cairo-trip-split-Malkia-curious-case-missing-passport-/1090-5232068-e61xcf/index.html">Part 2: Was Ramdoo sacrificed for Bitok?</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html"><img src="/image/view/-/5232028/lowRes/2418130/-/cb00cz/-/oku_pix.jpg" alt="Wazito head coach Stanley Okumbi watches his team during their" />
</a></figure>
<a href="/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html">Returning Wazito eager to hit the ground running</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/sports/athletics/Athletics-TaeKwonDo-protest-over-African-Games-quota/1100-5231996-9o56ylz/index.html"><img src="/image/view/-/5232006/lowRes/2418109/-/wfj53vz/-/tae_pix.jpg" alt="Safari Park Taekwondo Club Light Weight Milka Akinyi (right) spars" />
</a></figure>
<a href="/sports/athletics/Athletics-TaeKwonDo-protest-over-African-Games-quota/1100-5231996-9o56ylz/index.html">Athletics, Tae-Kwon-Do protest over African Games quota</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/oped/1192-1192-110kbth/index.html">Blogs &amp; Opinion</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/oped/blogs/620-620-obkqwq/index.html">Blogs</a><a href="/oped/opinion/440808-440808-h8w00fz/index.html">Commentaries</a><a href="/oped/editorial/440804-440804-id1ldp/index.html">Editorial</a><a href="/oped/cartoon/454986-454986-14tce6c/index.html">Cartoons</a></div>
<div class="main column">
<h4>Latest Blogs & Opinion</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/oped/opinion/Ejection-of-Zulekha-from-House-was-disrespectful/440808-5232128-rb85ovz/index.html"><img src="/image/view/-/5232132/lowRes/2418200/-/h0qdhez/-/odupic.jpg" alt="Kwale Woman Representative Zulekha Hassan. She was recently ejected" />
</a></figure>
<a href="/oped/opinion/Ejection-of-Zulekha-from-House-was-disrespectful/440808-5232128-rb85ovz/index.html">ODUMBE: MP’s ejection from House was disrespectful</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/oped/opinion/Provide-basic-necessities-and-go-slow-on-the-mega-projects/440808-5232116-avtdyhz/index.html"><img src="/image/view/-/5232118/lowRes/2418194/-/11niqnj/-/GUYPIC.jpg" alt="Workers on July 26, 2019 continue with the construction of Mama" />
</a></figure>
<a href="/oped/opinion/Provide-basic-necessities-and-go-slow-on-the-mega-projects/440808-5232116-avtdyhz/index.html">GUYO: Provide basic necessities and go slow on the mega projects</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/oped/opinion/How-to-create-job-opportunities-for-youth/440808-5232120-p4979fz/index.html"><img src="/image/view/-/5232126/lowRes/2418197/-/3nnp7/-/mtipic.jpg" alt="Young people on November 23, 2015 participate in the launch of" />
</a></figure>
<a href="/oped/opinion/How-to-create-job-opportunities-for-youth/440808-5232120-p4979fz/index.html">MTIKITIKI: How we can leverage the supply chain to create job</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/oped/opinion/Why-retirement-age-for-passwords-is-nigh/440808-5230926-a82gy9z/index.html"><img src="/image/view/-/5230932/lowRes/2417411/-/qsfvx9/-/WAMPIC.jpg" alt="Passwords are progressively being phased out. PHOTO | FILE | NATION" />
</a></figure>
<a href="/oped/opinion/Why-retirement-age-for-passwords-is-nigh/440808-5230926-a82gy9z/index.html">WAMBUGU: Why retirement age for passwords is nigh</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/lifestyle/1190-1190-5p56avz/index.html">Life &amp; Style</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
<a href="/lifestyle/artculture/1954194-1954194-7hp6o1/index.html">Art & Culture</a><a href="/lifestyle/family/1954198-1954198-jeojfi/index.html">Family</a><a href="/lifestyle/health/1954202-1954202-rynt7v/index.html">Health</a><a href="/lifestyle/showbiz/1950810-1950810-25qq0az/index.html">Showbiz</a><a href="/lifestyle/travel/1950822-1950822-ry3yf4/index.html">Travel</a><a href="/lifestyle/women/1950830-1950830-b0uq99z/index.html">Women & Style</a><a href="/lifestyle/magazines/2439396-2439396-u46yvl/index.html">Magazines</a></div>
<div class="main column">
<h4>Latest Life & Style</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/lifestyle/lifestyle/Our-moneymaking-plans-for-this-holiday/1214-5231814-yy2ej1z/index.html"><img src="/image/view/-/5231862/lowRes/2417984/-/p8i9xb/-/DREPIC.jpg" alt="We started arrangements to open the tuition centre: Dre-Lena" />
</a></figure>
<a href="/lifestyle/lifestyle/Our-moneymaking-plans-for-this-holiday/1214-5231814-yy2ej1z/index.html">STAFFROOM DIARY: Our moneymaking plans for this holiday</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/lifestyle/lifestyle/Why-men-hide-secret-children/1214-5231778-m3t2q9/index.html"><img src="/image/view/-/5231810/lowRes/2417960/-/2d2w7fz/-/maipic.jpg" alt="Admitting to having extramarital affair is not an easy thing to" />
</a></figure>
<a href="/lifestyle/lifestyle/Why-men-hide-secret-children/1214-5231778-m3t2q9/index.html">To tell or not: Why men hide &#039;secret&#039; children</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure class="">
<a href="/lifestyle/lifestyle/Camping-by-the-Ewaso/1214-5231760-uums7j/index.html"><img src="/image/view/-/5231764/lowRes/2417926/-/oril81/-/foxpic.jpg" alt="Camping by Ewaso River at Ol Pejeta Conservancy, in Laikipia" />
</a></figure>
<a href="/lifestyle/lifestyle/Camping-by-the-Ewaso/1214-5231760-uums7j/index.html">Camping by the Ewaso</a></div>
<div class="story-teaser tiny-teaser">
<figure class="">
<a href="/lifestyle/lifestyle/Always-fail-forward-and-learn-from-your-mistakes/1214-5231742-fqwf8nz/index.html"><img src="/image/view/-/5231754/lowRes/2417911/-/yagecz/-/harpic.jpg" alt="But you can choose how you react to your difficulties. And turn" />
</a></figure>
<a href="/lifestyle/lifestyle/Always-fail-forward-and-learn-from-your-mistakes/1214-5231742-fqwf8nz/index.html">MEN &amp; WOMEN: Always fail forward and learn from your mistakes</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/video/1951480-1951480-1072vroz/index.html">Videos</a><section class="mega-menu">
<div class="row">
<div class="aside column sub-menu">
</div>
<div class="main column">
<h4>Latest Videos</h4>
<div class="row">
<div class=" half column"><div class="story-teaser tiny-teaser">
<figure>
<a href="/video/news/4146788-5231858-dipll/index.html"><img src="https://img.youtube.com/vi/FRnSHDemsVk/mqdefault.jpg" alt="DP Ruto urges leaders to shun politics and focus on development" />
</a></figure>
<a href="/video/news/4146788-5231858-dipll/index.html"><span>11
&nbsp;hours&nbsp;ago</span>
DP Ruto urges leaders to shun politics and focus on development</a></div>
<div class="story-teaser tiny-teaser">
<figure>
<a href="/video/news/4146788-5231856-diplj/index.html"><img src="https://img.youtube.com/vi/tPHZVKgH4SA/mqdefault.jpg" alt="I didn't come here to address you, DP Ruto tells off journalists" />
</a></figure>
<a href="/video/news/4146788-5231856-diplj/index.html"><span>11
&nbsp;hours&nbsp;ago</span>
I didn&#039;t come here to address you, DP Ruto tells off journalists</a></div>
</div><div class=" half column"><div class="story-teaser tiny-teaser">
<figure>
<a href="/video/news/4146788-5231852-diplf/index.html"><img src="https://img.youtube.com/vi/d1fbPe4lNe8/mqdefault.jpg" alt="DP Ruto warns pastoralists communities against FGM" />
</a></figure>
<a href="/video/news/4146788-5231852-diplf/index.html"><span>11
&nbsp;hours&nbsp;ago</span>
DP Ruto warns pastoralists communities against FGM</a></div>
<div class="story-teaser tiny-teaser">
<figure>
<a href="/video/news/4146788-5231850-dipld/index.html"><img src="https://img.youtube.com/vi/oqixqdhBcko/mqdefault.jpg" alt="Step up war on graft Mudavadi tells Uhuru" />
</a></figure>
<a href="/video/news/4146788-5231850-dipld/index.html"><span>11
&nbsp;hours&nbsp;ago</span>
Step up war on graft Mudavadi tells Uhuru</a></div>
</div></div></div>
</div>
</section>
</li>
<li>
<a href="/photo/1951220-1951220-df7whxz/index.html">Photos</a><section class="mega-menu">
<div class="row">
 <div class="aside column sub-menu">
</div>
<div class="main column">
</div>
</div>
</section>
</li>
</ul>

<a class="btn-slide"><i class="fa fa-bars" aria-hidden="true"></i></a>

<div class="search-form clearfix">
<form id="searchHeader" name="searchfrm" action="/page/search/DailyNation/sports/football/1102-1102-view-asGoogleSearch-hiuius/index.html" method="get"><input name="q" type="search" placeholder="Search" />
<input type="submit" name="" value="" />
<input name="contextsIds" type="hidden" value="1148" />
<input name="sortBy" type="hidden" value="maupublicationdate" />
<input name="docTypes" type="hidden" value="&quot;MauArticle,MauGallery,MauVideo,CMDownload&quot;" />
</form></div>
</nav>
</header>
<article role="main" class="wrapper newsplex-article">

<section class="top-ad full-width">
<div class="container">
</div>
</section>

<section role="main" class="main-home artTop ">
<section class="top-ad full-width">
<div class="container">
<!-- google_ad_section_start -->
<script> 
var domainpath=window.location.pathname.split( '/' );
if(domainpath.length>4){}else{
googletag.cmd.push(function() {





window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }








var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [[970, 90], [728, 90]]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();
googletag.defineSlot('/1010816/DN-slimmy-950x65', [[970, 90], [728, 90], [300, 250]], 'div-gpt-ad-1493111126853-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());





 

googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();

});
}
</script>

<div id='div-gpt-ad-1493111126853-0' style='margin:0 auto;height:auto'>
<script>
if(domainpath.length>4){}else{
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1493111126853-0'); });
}
</script>
</div><!-- google_ad_section_end -->
</div>
</section>

<section class="">
<div class="container">
<div class="row">

<article class="main column">
<section class="ad noprint">
<div class="ad">
<!-- google_ad_section_start -->
<script>
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();





window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }








googletag.defineSlot('/1010816/Z-DN-728x90-ArticleTop',[[728, 90], [300, 250]], 'div-gpt-ad-1489467324804-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1489467324804-0' style='margin:0 auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1489467324804-0'); });
</script>
</div><!-- google_ad_section_end -->
</div>
</section>
<div class="story-view">
<div class="section-home-header clearfix noprint">
<ol class="breadcrumb">
<li class="breadcrumb-item"><a href="/1148-1148-hfsx23z/index.html">Home</a></li>
<li class="breadcrumb-item"><a href="/sports/1090-1090-iqcgwe/index.html">Sports</a></li>
<li class="breadcrumb-item"><a href="/sports/football/1102-1102-5p3gunz/index.html">Football</a></li>
</ol>
</div>
<header>
<h2>Returning Wazito eager to hit the ground running </h2>
<p class="summary"><h6>Monday August 12 2019</h6><p class="noprint"><div class="social-networks noprint">
<a href="https://twitter.com/share?text=Returning Wazito eager to hit the ground running&amp;url=https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html&amp;via=dailynation" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/sharer.php?u=https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html" target="_blank"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<div class="mobileShow">
<a href="whatsapp://send?text=https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html" target="_blank"><i class="fa fa-whatsapp" aria-hidden="true"></i></a>
</div>
<a href="javascript:window.print()" target="_blank"><i class="fa fa-print" aria-hidden="true"></i></a>
<a href="/cdn-cgi/l/email-protection#8de3ece0e8cde8e0ece4e1a3eee2e0b2fef8efe7e8eef9b0dfe8f9f8ffe3e4e3eaaddaecf7e4f9e2ade8eceae8ffadf9e2ade5e4f9adf9e5e8adeaffe2f8e3e9adfff8e3e3e4e3eaabefe2e9f4b0dfe8f9f8ffe3e4e3eaaddaecf7e4f9e2ade8eceae8ffadf9e2ade5e4f9adf9e5e8adeaffe2f8e3e9adfff8e3e3e4e3eaa0e5f9f9fdfeb7a2a2fafafaa3e3ecf9e4e2e3a3eee2a3e6e8a2fefde2fff9fea2ebe2e2f9efece1e1a2dfe8f9f8ffe3e4e3eaa0daecf7e4f9e2a0e8eceae8ffa0f9e2a0e5e4f9a0f9e5e8a0eaffe2f8e3e9a0fff8e3e3e4e3eaa2bcbcbdbfa0b8bfbebfbdbfb9a0ffebf5ecf8eef7a2e4e3e9e8f5a3e5f9e0e1" target="_blank"><i class="fa fa-envelope-o" aria-hidden="true"></i></a>
</div></p>
<div>
<img class="photo_article" src="/image/view/-/5232028/highRes/2418132/-/maxw/600/-/3j67unz/-/oku_pix.jpg" alt="Wazito head coach Stanley Okumbi watches his team during their friendly match against Muranga Seal at GEMS International Cambridge School , Nairobi on August 11, 2019. PHOTO | SILA KIPLAGAT |" />
<p id="photo_article_caption">
Wazito head coach Stanley Okumbi watches his team during their friendly match against Muranga Seal at GEMS International Cambridge School , Nairobi on August 11, 2019. PHOTO | SILA KIPLAGAT | &nbsp;NATION MEDIA GROUP</p>
</div>
</header>
<article class="article">
<section class="article-sidebar">
<section class="summary">
<h4>In Summary</h4 >
<div><ul><li>The team has signed up several big names as well as exciting talent as they shape up for the new season</li><li>The club's Sporting Director Solomon Alubala says they have learnt their lessons and are returning to the top-tier league stronger</li><li>The team could, however, be without young Musa Masika who is said to be on his way out of the club</li></ul></div></section>
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<!-- google_ad_section_start -->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
googletag.cmd.push(function() {





window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }





var REFRESH_KEY = 'refresh';
var REFRESH_VALUE = 'true';
  googletag.defineSlot('/1010816/DN-worldcup-300x250', [300, 250], 'div-gpt-ad-1529676065626-0').addService(googletag.pubads());
var SECONDS_TO_WAIT_AFTER_VIEWABILITY = 60;
googletag.pubads().addEventListener('impressionViewable', function(event) {
var slot = event.slot;
if (slot.getTargeting(REFRESH_KEY).indexOf(REFRESH_VALUE) > -1) {
setTimeout(function() {
googletag.pubads().refresh([slot]);
}, SECONDS_TO_WAIT_AFTER_VIEWABILITY * 1000);
}
});

googletag.enableServices();
});
</script>
 

<div id='div-gpt-ad-1529676065626-0' class='adSquare'>
<script>

googletag.cmd.push(function() { googletag.display('div-gpt-ad-1529676065626-0'); });

</script>
</div><!-- google_ad_section_end -->
</div>
</section>
</section>
<section class="body-copy">
<section class="author noprint">
<figure class="left">
<img src="/image/view/-/1994480/medRes/2410565/-/esduwj/-/Jeff+Kinyanjui.jpg" width="50" alt="JEFF KINYANJUI" />
</figure>
<strong>By JEFF KINYANJUI</strong><br />
<a href="/authors/1959272-1993480-view-asAuthor-3gwylcz/index.html"><span class="author-profile">More by this Author</span>
</a></section>
<div><p>Kenyan Premier League returnees Wazito FC are out to make a strong statement in the 2019/20 season which starts on August 30.</p></div><div><p>The team has signed up several big names as well as exciting talent as they shape up for the new season.</p></div><div><p>Former Gor Mahia fullbacks Karim Nizigiyimana and Abouba Sibomana headline the new signings that include young talents such as Joshua Otieno, Kevin Omondi and Derrick Otanga from Sony Sugar FC as well as experienced striker Elvis Rupia who joins the club from Zambian side Power Dynamos. In total, the team has registered 11 new players and with the transfer window still open, they could rope in more.</p></div><div><p>The club's Sporting Director Solomon Alubala says they have learnt their lessons and are returning to the top-tier league stronger.</p></div><div><p>“We are now more organised as a club and have clear intentions of what we want to achieve in the KPL this season. That has informed the kind of players we have brought in. We need that quality if we are to compete at the top level. We are coming back not just as mere participants but to compete.” Alubala told <em>Nation Sport</em>.</p></div><div><p>Former Harambee Stars tactician Stanley Okumbi, who leads Wazito’s technical team echoed Alubala’s sentiments.</p></div><div id="relatedCoverage" class="article-related-coverage noprint">
<div class="related-coverage-header"><h4>Related Stories</h4></div>
<div class="related-coverage-body">
<ul>
<li>
<a href="https://www.nation.co.ke/sports/football/Rupia-sets-ambitious-targets-at-Wazito/1102-5231624-4b9j2yz/index.html">
<span class="relImage">
<figure>
<img class="lazy-loaded" src="/image/view/-/5232030/medRes/2418128/-/kx1swl/-/rupia_pix.jpg" alt="Rupia sets ambitious targets at Wazito">
</figure>
</span>
<span class="relText">Rupia sets ambitious targets at Wazito</span>
</a>
</li>
</ul>
</div>
</div>
<div><p>“We have some new players that we have brought into the team and they are gelling well. We have played several friendly matches and I am happy with the progress so far – the team is coming up well. We are not at 100 per cent yet but we have about two weeks to finalise on the preparations and we will be okay.” “We are coming back to correct the mistakes Wazito made during their debut in the league. The new players have to gel as soon as possible, it is not easy but we are working on it. Our target is to compete in the league and I think we are ready. I believe if we get our cards right then we have a chance to do a marvellous job this season,” he added.</p></div><div><p>The team could, however, be without young Musa Masika who is said to be on his way out of the club. Okumbi is however optimistic they will fill in the gap in case the player leaves. </p></div><div><p>“Musa was not really sharp and fit when he initially joined the team but we worked on it and he improved and gelled well. I’m not sure if he has left officially but if he does I don’t think it will be a big loss as the league is yet to start. We still have a chance to make another good player to fit into that position because our job is to mould players,” he said.</p></div><div><p>Former Gor midfielder Ali Abondo is among those trying out at the club. “Our team does not have a lot of experienced players at the moment and therefore if he proves to us that he has what it takes then we will sign him up. He has been working hard and he has one more week to prove himself,” Okumbi said.</p></div><div><p>Ali returned to the country after short spells in South Africa with top-tier sides Ajax Capetown and Bloemfontein Celtic. </p></div><div><p>The team beat National Super League (NSL) newbies Muranga Sports Excellence Academy 2-0 in a friendly match at the GEMS Cambridge International School on Sunday morning.</p></div><div><p>They are set for a week’s camp in Oloitoktok and will also cross over to Tanzania for a series of friendly matches.</p></div><p class="summary noprint"><div class="social-networks noprint">
<a href="https://twitter.com/share?text=Returning Wazito eager to hit the ground running&amp;url=https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html&amp;via=dailynation" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/sharer.php?u=https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html" target="_blank"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<div class="mobileShow">
<a href="whatsapp://send?text=https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html" target="_blank"><i class="fa fa-whatsapp" aria-hidden="true"></i></a>
</div>
<a href="javascript:window.print()" target="_blank"><i class="fa fa-print" aria-hidden="true"></i></a>
<a href="/cdn-cgi/l/email-protection#3759565a5277525a565e5b1954585a084442555d5254430a6552434245595e59501760564d5e4358175256505245174358175f5e4317435f521750455842595317454259595e5950115558534e0a6552434245595e59501760564d5e4358175256505245174358175f5e4317435f521750455842595317454259595e59501a5f434347440d1818404040195956435e5859195458195c5218444758454344185158584355565b5b186552434245595e59501a60564d5e43581a52565052451a43581a5f5e431a435f521a5045584259531a454259595e595018060607051a020504050705031a45514f5642544d185e5953524f195f435a5b" target="_blank"><i class="fa fa-envelope-o" aria-hidden="true"></i></a>
</div></p>
</section>
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<!-- google_ad_section_start -->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
googletag.cmd.push(function() {





window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }


var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [970, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();
googletag.defineSlot('/1010816/Z-DN-728x90-sportsArticleEnd', [[300, 250], [728, 90]], 'div-gpt-ad-1510123995123-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1510123995123-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510123995123-0'); });
</script>
</div><!-- google_ad_section_end -->
</div>
</section>

<div id="disqus_thread"></div>
<script>
					var disqus_config = function () {
					this.page.url = 'https://www.nation.co.ke/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html';  // Replace PAGE_URL with your page's canonical URL variable
					this.page.identifier = '5232024'; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
					};				
					(function() { // DON'T EDIT BELOW THIS LINE
					var d = document, s = d.createElement('script');
					s.src = 'https://dailynation.disqus.com/embed.js';
					s.setAttribute('data-timestamp', +new Date());
					(d.head || d.body).appendChild(s);
					})();
					</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<br clear="all">
<div class="noprint">
<div class="noprint">
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
							window._taboola = window._taboola || [];
							_taboola.push({
								mode: 'thumbnails-a',
								container: 'taboola-below-article-thumbnails',
								placement: 'Below Article Thumbnails',
								target_type: 'mix'
							});
						</script>
</div>
</div>
<section class="print-section big-blog noprint" id="headlines">
<header class="clearfix">
<div class="blog-header clearfix">
<h3>In the headlines</h3>
</div>
</header>
<article>
<div class="row">
<div class="five-eight column">
<div class="story-teaser medium-teaser">
<h3> <a href="/news/Matiangi-renews-drug-war-after-Bamburi-attacks/1056-5232044-13ptjl2z/index.html">Matiang&#039;i renews drug war after Bamburi attacks</a></h3>
<div class="">
<figure class="">
<a href="/news/Matiangi-renews-drug-war-after-Bamburi-attacks/1056-5232044-13ptjl2z/index.html">
<img class="lazy-loaded" src="/image/view/-/5232060/medRes/2418155/-/ggev2v/-/matpic.jpg" alt="Matiang'i renews drug war after Bamburi attacks">
</a>
</figure>
<p>
He said results, not promises, will give Kenyans assurance of their safety. </p>
</div>
</div>
<div class="story-teaser medium-teaser">
<h3> <a href="/news/President-Uhuru-Kenyatta-on-global-charm-offensive/1056-5231632-9l8153z/index.html">Revealed: Secrets of Uhuru foreign trips</a></h3>
<div class="">
<figure class="">
<a href="/news/President-Uhuru-Kenyatta-on-global-charm-offensive/1056-5231632-9l8153z/index.html">
<img class="lazy-loaded" src="/image/view/-/5231630/medRes/2417848/-/4v9l0d/-/UHURU+1+TRIPS.jpg" alt="Revealed: Secrets of Uhuru foreign trips">
</a>
</figure>
<p>Mission has an impact on economy, security and the battle for control of the Indian Ocean</p>
</div>
</div>
</div>
<div class="three-eight column">
<div class="small-story-list">
<h5 class="small-story-list"><a href="/sports/Cairo-trip-split-Malkia-curious-case-missing-passport-/1090-5232068-e61xcf/index.html">Part 2: Was Ramdoo sacrificed for Bitok?</a></h5>
<h5 class="small-story-list"><a href="/news/Prison-bosses-moved-in-reshuffle/1056-5231428-138aybjz/index.html">Reshuffle as prison breaks taint police image</a></h5>
<h5 class="small-story-list"><a href="/sports/athletics/Athletics-TaeKwonDo-protest-over-African-Games-quota/1100-5231996-9o56ylz/index.html">Athletics, Tae-Kwon-Do protest over African Games quota</a></h5>
<h5 class="small-story-list"><a href="/counties/mombasa/Muslims-mark-Idd-ul-Adha/1954178-5231326-r8bnl1/index.html">Muslims hold Idd-ul-Adha prayers</a></h5>
<h5 class="small-story-list"><a href="/counties/kisii/Ex-Minister-Hezron-Manduku-dies/1183286-5231214-q0gbco/index.html">Ex-Minister Hezron Manduku dies at 79</a></h5>
</div>
</div>
</div>
</article>
</section>
</article>
</div>
<script type="text/javascript">
	  /* CONFIGURATION START */
	  var _ain = {
		id: "1714",
		postid: "5232024",
		maincontent: "h2, #photo_article_caption, section.summary, section.body-copy",
		title: "Returning Wazito eager to hit the ground running  ",
		pubdate: "2019-08-12 02:10:49",		
		authors: "JEFF KINYANJUI",		    
		sections: "Football",
		tags: "JEFF KINYANJUI, Kenyan Premier League, Wazito, Stanley Okumbi, Solomon Alubala, Musa Masika, ",
		comments: ""
	  };
	  /* CONFIGURATION END */
	  (function(d,s){var sf=d.createElement(s);sf.type='text/javascript';sf.async=!0;sf.src=(('https:'==d.location.protocol)?'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com':'http://t.contentinsights.com')+'/stf.js';var t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(sf,t)})(document,'script')
	</script>
<script>		
		var author = 'JEFF KINYANJUI';		
		ga('set', 'dimension1', author);
		var pubdate = '2019-08-12 02:10:49';
		ga('set', 'dimesion2', pubdate);
	</script>
<script>
	  dataLayer = [{
		'site': 'https://www.nation.co.ke',
		'section': 'Football',
		//'subsection': 'business',
		'pageTitle': 'Returning Wazito eager to hit the ground running  ',
		//'pageCategory': 'money markets',
		'author': 'JEFF KINYANJUI',		
		'keywords': ['JEFF KINYANJUI',' Kenyan Premier League',' Wazito',' Stanley Okumbi',' Solomon Alubala',' Musa Masika',' ']
	 }];
	</script>
</article>


<aside class="aside column noprint">
<div class="row">
<!-- google_ad_section_start -->
<script>
googletag.cmd.push(function() {





window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }


googletag.defineSlot('/1010816/Z-dn-300x250-sportsins3', [300, 250], 'div-gpt-ad-1544167347534-0').addService(googletag.pubads());
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1544167347534-0' class='adSquare'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1544167347534-0'); });
</script>
</div><!-- google_ad_section_end -->
<!-- google_ad_section_start -->
<div class="mailchimp-container"><div class="mp-logo"> <img src="https://cdn.nation.co.ke/mailchimp/dn-logo.png" alt="Daily Nation"></div><h2> NEVER MISS A STORY</h2><p> Get Breaking News Delivered to your Inbox</p><form action="https://nation.us16.list-manage.com/subscribe/post?u=0fd426a35325118486f65036d&amp;id=814d50c894" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate get-news" target="_blank" novalidate><div class="mp-field"><div class="textbox-with-icon"> <input type="email" class="textbox" id="mce-EMAIL" name="EMAIL" maxlength="100" placeholder="Email"></div><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_0fd426a35325118486f65036d_814d50c894" tabindex="-1" value=""></div></div><div id="error" style="color: #FF0000"></div><div id="success" style="color: #008000"></div><div class="mp-field last"> <button class="submit-btn" name="subscribe" id="mc-embedded-subscribe" type="submit">Subscribe</button></div></form><div class="alerts-title"><h2>News On The Go</h2></div> <a href="http://whatsapp.nation.co.ke/" class="scribe-to-link whatsapp" target="_blank"><div class="scribe-to"><div class="scribe-icon"> <i class="fa fa-whatsapp" aria-hidden="true"></i></div><div class="scribe-text-c"> <span>WhatsApp</span></div><div class="scribe-btn-o"> <span>Subscribe</span></div></div> </a> <a href="https://www.facebook.com/messages/t/DailyNation" class="scribe-to-link facebook" target="_blank"><div class="scribe-to"><div class="scribe-icon"> <span class="bg-cl"></span> <svg viewBox="0 0 128 128" xml:space="preserve"><g><g id="Facebook_Messenger_1_"><rect clip-rule="evenodd" fill="none" fill-rule="evenodd" height="35" width="35" /><path clip-rule="evenodd" d="M70.36,79.802L54.062,62.42 L22.261,79.802l34.981-37.136l16.696,17.383l31.404-17.383L70.36,79.802z M64,0C28.654,0,0,26.531,0,59.259 c0,18.649,9.307,35.283,23.851,46.146V128l21.791-11.96c5.816,1.609,11.977,2.478,18.358,2.478c35.346,0,64-26.531,64-59.259 S99.346,0,64,0z" fill="#007FFF" fill-rule="evenodd" id="Facebook_Messenger" /></g></g></svg></div><div class="scribe-text-c"> <span>Facebook Messenger</span></div><div class="scribe-btn-o"> <span>Subscribe</span></div></div> </a> <a href="https://t.me/joinchat/AAAAAEFe-Usn27J-bxu6Dw" class="scribe-to-link telegram" target="_blank"><div class="scribe-to"><div class="scribe-icon"> <svg style="enable-background:new 0 0 512 512;" viewBox="0 0 512 512" xml:space="preserve"><style type="text/css">.st0{fill:url(#SVGID_1_)}.st1{fill:#FFF}.st2{fill:#D2E4F0}.st3{fill:#B5CFE4}</style><g><linearGradient gradientUnits="userSpaceOnUse" id="SVGID_1_" x1="256" x2="256" y1="0" y2="510.1322"><stop offset="0" style="stop-color:#41BCE7" /><stop offset="1" style="stop-color:#22A6DC" /></linearGradient><circle class="st0" cx="256" cy="256" r="256" /><g><path class="st1" d="M380.6,147.3l-45.7,230.5c0,0-6.4,16-24,8.3l-105.5-80.9L167,286.7l-64.6-21.7c0,0-9.9-3.5-10.9-11.2 c-1-7.7,11.2-11.8,11.2-11.8l256.8-100.7C359.5,141.2,380.6,131.9,380.6,147.3z" /><path class="st2" d="M197.2,375.2c0,0-3.1-0.3-6.9-12.4c-3.8-12.1-23.3-76.1-23.3-76.1l155.1-98.5c0,0,9-5.4,8.6,0 c0,0,1.6,1-3.2,5.4c-4.8,4.5-121.8,109.7-121.8,109.7" /><path class="st3" d="M245.8,336.2l-41.7,38.1c0,0-3.3,2.5-6.8,0.9l8-70.7" /></g></g></svg></div><div class="scribe-text-c"> <span>Telegram</span></div><div class="scribe-btn-o"> <span>Subscribe</span></div></div> </a></div><!-- google_ad_section_end -->


<div class="sidebar-item">
<div class="tab-header">
<div class="tab">
<span class="icon most-read-icon"></span>Latest</div>
</div>
<div class="tab-body">

<li class="most-popular-item">
<a href="/sports/football/Emery-impressed-despite-Arsenal-slim-win-Newcastle/1102-5232094-10pfp2dz/index.html">
<span class="most-number">1</span>
<span class="most-headline"><span>Football</span> Emery impressed despite Arsenal&#039;s slim win</span>
</a>
</li>

<li class="most-popular-item">
<a href="/sports/Cairo-trip-split-Malkia-curious-case-missing-passport-/1090-5232068-e61xcf/index.html">
<span class="most-number">2</span>
<span class="most-headline"><span>Sports</span> Part 2: Was Ramdoo sacrificed for Bitok?</span>
</a>
</li>

<li class="most-popular-item">
<a href="/sports/football/Returning-Wazito-eager-to-hit-the-ground-running/1102-5232024-rfxaucz/index.html">
<span class="most-number">3</span>
<span class="most-headline"><span>Football</span> Returning Wazito eager to hit the ground running</span>
</a>
</li>

<li class="most-popular-item">
<a href="/sports/athletics/Athletics-TaeKwonDo-protest-over-African-Games-quota/1100-5231996-9o56ylz/index.html">
<span class="most-number">4</span>
<span class="most-headline"><span>Athletics</span> Athletics, Tae-Kwon-Do protest over African Games quota</span>
</a>
</li>

<li class="most-popular-item">
<a href="/oped/opinion/Ejection-of-Zulekha-from-House-was-disrespectful/440808-5232128-rb85ovz/index.html">
<span class="most-number">5</span>
<span class="most-headline"><span>Commentaries</span> ODUMBE: MP’s ejection from House was disrespectful</span>
</a>
</li>

<li class="most-popular-item">
<a href="/oped/opinion/Provide-basic-necessities-and-go-slow-on-the-mega-projects/440808-5232116-avtdyhz/index.html">
<span class="most-number">6</span>
<span class="most-headline"><span>Commentaries</span> GUYO: Provide basic necessities and go slow on the mega projects</span>
</a>
</li>
</div>
</div>
<div class="ad">
<!-- google_ad_section_start -->
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/Z-DN-300x250-sports-ins2', [300, 250], 'div-gpt-ad-1543240364125-0').addService(googletag.pubads());
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1543240364125-0' class='adSquare'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1543240364125-0'); });
</script>
</div>
<!-- google_ad_section_end -->
 </div>
<section class="sidebar-item">
<header class="tab-header">
<div class="tab"><span class="icon gallery"></span>
LATEST NTV VIDEOS</div>
</header>
<article class="tab-body">
<div class="whole ntv-most-viewed">
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5226814-x5embhz/index.html"><img src="https://img.youtube.com/vi/qoI9anRv7Wo/mqdefault.jpg" alt="Face behind the terror gangs of Mombasa: Wakali Wao, Wakali Kwanza || Am Live"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5226814-x5embhz/index.html">Face behind the terror gangs of Mombasa: Wakali Wao, Wakali Kwanza || Am Live</a></p>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5226810-x5emblz/index.html"><img src="https://img.youtube.com/vi/2euLVGO9v9Y/mqdefault.jpg" alt="DP Ruto is not the automatic Jubilee candidate in 2022 - CS Tuju"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5226810-x5emblz/index.html">DP Ruto is not the automatic Jubilee candidate in 2022 - CS Tuju</a></p>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5226804-x5emcdz/index.html"><img src="https://img.youtube.com/vi/Ntb8cc1fQeI/mqdefault.jpg" alt="Kwale Woman Rep causes drama in parliament after walking in with her baby"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5226804-x5emcdz/index.html">Kwale Woman Rep causes drama in parliament after walking in with her baby</a></p>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5223478-x5gs9ez/index.html"><img src="https://img.youtube.com/vi/JZOOrKhVvgg/mqdefault.jpg" alt="I will operate Kiambu county affairs at sub-county level - Governor Waititu"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5223478-x5gs9ez/index.html">I will operate Kiambu county affairs at sub-county level - Governor Waititu</a></p>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5214942-x62j03z/index.html"><img src="https://img.youtube.com/vi/xZkLHvKPrFw/mqdefault.jpg" alt="Kenya Morans scoop silver in first continental final in country history"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5214942-x62j03z/index.html">Kenya Morans scoop silver in first continental final in country history</a></p>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-sm-12 col-md-12">
<a href="https://ntv.nation.co.ke/news/2720124-5214928-x62j1oz/index.html"><img src="https://img.youtube.com/vi/j_iWtBEsLIk/mqdefault.jpg" alt="BREAKING NEWS: Governor Joyce Laboso is dead"></a>
<p><a href="https://ntv.nation.co.ke/news/2720124-5214928-x62j1oz/index.html">BREAKING NEWS: Governor Joyce Laboso is dead</a></p>
</div>
</div>
</div>
</article>

</section>

<div class="sidebar-item">
<div class="ad">
<span>Advertisement</span>
<!-- google_ad_section_start -->
 <script>googletag.cmd.push(function() {





window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }




googletag.defineSlot('/1010816/Z-DN-300x250-sports-ins', [300, 250], 'div-gpt-ad-1543222911884-0').addService(googletag.pubads()); googletag.enableServices();});</script>
 <div id='div-gpt-ad-1543222911884-0' class='adSquare'><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1543222911884-0'); });</script></div>
<!-- google_ad_section_end -->
</div>
</div>
<!-- google_ad_section_start -->
<div class="nfmPlayer">
<audio controls name="media"><source src="https://stream.radiojar.com/3by7s8eg65quv" type="audio/mpeg"></audio>
</div><!-- google_ad_section_end -->
<div class="clearfix"></div>
<div class="tab-header" style="margin-top:1em;">
<div class="tab"><span class="icon most-read-icon"></span>Latest Nairobi News</div>
</div>
<iframe src="https://nairobinews.nation.co.ke/dn-widget/" height="600" width="355" frameborder="0" scrolling="auto" id="nn-iframe"> </iframe>
<!-- google_ad_section_start -->
<script>

  window.googletag = window.googletag || {cmd: []};

  googletag.cmd.push(function() {

    googletag.defineSlot('/1010816/Z-DN-article-rightpanel', [300, 250], 'div-gpt-ad-1564563127559-0').addService(googletag.pubads());

    googletag.pubads().enableSingleRequest();

    googletag.enableServices();

  });

</script>​ 

<div id='div-gpt-ad-1564563127559-0' style='width: 300px; height: 250px;'>
  <script>

    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1564563127559-0'); });

  </script>
</div><!-- google_ad_section_end -->
</div>
</aside>
</div>
</div>
</section>
</section>
</article>
<footer class="footer section">
<div class="container">
<div class="row">
<div class="main column">
</div>
<div class="aside column"></div>
</div>
</div>
</footer>
<footer class="wrapper page-footer" id="page-footer">

<div class="menu-holder menu-holder-footer noprint">
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/news/1056-1056-u6geog/index.html" title="News"><h3 class="footer-section-heading">News</h3></a>
</header>
<a href="https://www.nation.co.ke/news/politics/1064-1064-4f88toz/index.html" title="Politics">Politics</a>
<a href="https://www.nation.co.ke/news/africa/1066-1066-oo1nedz/index.html" title="Africa">Africa</a>
<a href="https://www.nation.co.ke/news/world/1068-1068-y0kl4cz/index.html" title="World">World</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/business/996-996-x0uutpz/index.html" title="Business"><h3 class="footer-section-heading">Business</h3></a>
</header>
<a href="https://www.nation.co.ke/business/seedsofgold/2301238-2301238-e2g5gz/index.html" title="Seeds of Gold">Seeds of Gold</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/counties/1107872-1107872-44rd16z/index.html" title="Counties"><h3 class="footer-section-heading">Counties</h3></a>
</header>
<a href="https://www.nation.co.ke/counties/coast/3347800-3347800-ey6rn8z/index.html" title="Coast">Coast</a>
<a href="https://www.nation.co.ke/counties/northern-region/3347734-3347734-155vfigz/index.html" title="Northern">Northern</a>
<a href="https://www.nation.co.ke/counties/eastern-region/3347810-3347810-2501vq/index.html" title="Eastern">Eastern</a>
<a href="https://www.nation.co.ke/counties/mtkenya/3317830-3317830-7p8g5w/index.html" title="Mt Kenya ">Mt Kenya </a>
<a href="https://www.nation.co.ke/counties/north-rift/3347778-3347778-aga2m3z/index.html" title="North Rift">North Rift</a>
<a href="https://www.nation.co.ke/counties/south-rift/3347782-3347782-rtpd5y/index.html" title="South Rift">South Rift</a>
<a href="https://www.nation.co.ke/counties/western-region/3347786-3347786-nvg1d5/index.html" title="Western">Western</a>
<a href="https://www.nation.co.ke/counties/nyanza-kisii-region/3347796-3347796-unywdg/index.html" title="Nyanza-Kisii">Nyanza-Kisii</a>
<a href="https://www.nation.co.ke/counties/nairobi/1954174-1954174-swx4nez/index.html" title="Nairobi">Nairobi</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/sports/1090-1090-iqcgwe/index.html" title="Sports"><h3 class="footer-section-heading">Sports</h3></a>
</header>
<a href="https://www.nation.co.ke/sports/football/1102-1102-5p3gunz/index.html" title="Football">Football</a>
<a href="https://www.nation.co.ke/sports/athletics/1100-1100-g06rtez/index.html" title="Athletics">Athletics</a>
<a href="https://www.nation.co.ke/sports/rugby/1106-1106-g0i5l0z/index.html" title="Rugby">Rugby</a>
<a href="https://www.nation.co.ke/sports/golf/1104-1104-hjqyif/index.html" title="Golf">Golf</a>
<a href="https://www.nation.co.ke/sports/othersports/1951306-1951306-fy284lz/index.html" title="Others">Others</a>
<a href="https://www.nation.co.ke/sports/talkup/441392-441392-wkoe7h/index.html" title="TalkUp">TalkUp</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/oped/1192-1192-110kbth/index.html" title="Blogs & Opinion"><h3 class="footer-section-heading">Blogs &amp; Opinion</h3></a>
</header>
<a href="https://www.nation.co.ke/oped/blogs/620-620-obkqwq/index.html" title="Blogs">Blogs</a>
<a href="https://www.nation.co.ke/oped/opinion/440808-440808-h8w00fz/index.html" title="Commentaries">Commentaries</a>
<a href="https://www.nation.co.ke/oped/editorial/440804-440804-id1ldp/index.html" title="Editorial">Editorial</a>
<a href="https://www.nation.co.ke/oped/cartoon/454986-454986-14tce6c/index.html" title="Cartoons">Cartoons</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/lifestyle/1190-1190-5p56avz/index.html" title="Life & Style"><h3 class="footer-section-heading">Life &amp; Style</h3></a>
</header>
<a href="https://www.nation.co.ke/lifestyle/artculture/1954194-1954194-7hp6o1/index.html" title="Art & Culture">Art &amp; Culture</a>
<a href="https://www.nation.co.ke/lifestyle/family/1954198-1954198-jeojfi/index.html" title="Family">Family</a>
<a href="https://www.nation.co.ke/lifestyle/health/1954202-1954202-rynt7v/index.html" title="Health">Health</a>
<a href="https://www.nation.co.ke/lifestyle/showbiz/1950810-1950810-25qq0az/index.html" title="Showbiz">Showbiz</a>
<a href="https://www.nation.co.ke/lifestyle/travel/1950822-1950822-ry3yf4/index.html" title="Travel">Travel</a>
<a href="https://www.nation.co.ke/lifestyle/women/1950830-1950830-b0uq99z/index.html" title="Women & Style">Women &amp; Style</a>
<a href="https://www.nation.co.ke/lifestyle/magazines/2439396-2439396-u46yvl/index.html" title="Magazines">Magazines</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/video/1951480-1951480-1072vroz/index.html" title="Videos"><h3 class="footer-section-heading">Videos</h3></a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="https://www.nation.co.ke/photo/1951220-1951220-df7whxz/index.html" title="Photos"><h3 class="footer-section-heading">Photos</h3></a>
</header>
</nav>
</div>
<footer id="dnFooter">
<div class="dnFooter-row noprint">
<div class="dnFooter-col-sm-3">
<h5></h5>
<form action="https://nation.us16.list-manage.com/subscribe/post?u=0fd426a35325118486f65036d&amp;id=814d50c894" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate get-news" target="_blank" novalidate>
<div class="mp-field">
<div class="textbox-with-icon">
<input type="email" class="textbox" id="mce-EMAIL" name="EMAIL" maxlength="100" placeholder="Email">
</div>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_0fd426a35325118486f65036d_814d50c894" tabindex="-1" value=""></div>
</div>
<div id="error" style="color: #FF0000"></div>
<div id="success" style="color: #008000"></div>
<div class="mp-field last">
<button class="submit-btn" name="subscribe" id="mc-embedded-subscribe" type="submit">Subscribe</button>
</div>
</form>
<h5></h5>
<a href="https://www.nation.co.ke"><img src="https://www.nation.co.ke/nationmedia/css/icons/dailynation/dnLogoFooter.png" alt="Daily Nation" class="logo" /></a>
</div>
<div class="dnFooter-col-sm-2">
<h5>Apps</h5>
<ul>
<li><a href='https://play.google.com/store/apps/developer?id=Nation%20Media%20Group&hl=en&pcampaignid=MKT-Other-global-all-co-prtnr-py-PartBadge-Mar2515-1' target='_blank'><img alt='Play Store' src='https://www.nation.co.ke/nationmedia/css/icons/dailynation/google-play-badge.png' /></a></li><br>
<li><a href="https://itunes.apple.com/us/developer/nation-media-group-ltd/id771736086" target="_blank"><img src="https://www.nation.co.ke/nationmedia/css/icons/dailynation/appStoreIcon.svg" alt="App Store" class="logo" /></a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>Information</h5>
<ul>
<li><a href="https://www.nation.co.ke/meta/1194-1174-byky0p/index.html" title="Contact Us">Contact Us</a></li><li><a href="https://www.nation.co.ke/meta/1194-1184-byky1l/index.html" title="FAQ">FAQ</a></li><li><a href="http://epaper.nationmedia.com" title="E-papers">E-papers</a></li><li><a href="https://www.nation.co.ke/meta/1194-1182-byky1j/index.html" title="Privacy Policy">Privacy Policy</a></li><li><a href="https://www.nation.co.ke/meta/1194-1186-byky1n/index.html" title="Terms">Terms</a></li></ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>NMG Sites</h5>
<ul>
<li><a href="https://pishi.co.ke/" target="_blank" title="Pishi">Pishi</a></li><li><a href="http://lit360.africa" target="_blank" title="Lit360">Lit360</a></li><li><a href="http://transitions.nation.co.ke/" target="_blank" title="Nation Transitions">Nation Transitions</a></li><li><a href="https://nairobinews.nation.co.ke" target="_blank" title="Nairobi News">Nairobi News</a></li><li><a href="http://www.businessdailyafrica.com/" target="_blank" title="Business Daily">Business Daily</a></li><li><a href="https://ntv.nation.co.ke" target="_blank" title="NTV">NTV</a></li><li><a href="http://www.ntv.co.ug" target="_blank" title="NTV Uganda">NTV Uganda</a></li><li><a href="http://www.monitor.co.ug/" target="_blank" title="Daily Monitor">Daily Monitor</a></li><li><a href="http://www.thecitizen.co.tz/" target="_blank" title="The Citizen">The Citizen</a></li><li><a href="http://www.mwananchi.co.tz/" target="_blank" title="Mwananchi">Mwananchi</a></li><li><a href="http://www.mwanaspoti.co.tz" target="_blank" title="Mwanaspoti">Mwanaspoti</a></li><li><a href="http://taifaleo.nation.co.ke/" target="_blank" title="Taifa Leo">Taifa Leo</a></li><li><a href="http://www.swahilihub.com/" target="_blank" title="Swahili Hub">Swahili Hub</a></li><li><a href="http://www.theeastafrican.co.ke" target="_blank" title="The EastAfrican">The EastAfrican</a></li><li><a href="http://www.nationmedia.com" target="_blank" title="Nation Media Group">Nation Media Group</a></li></ul>
</div>
<div class="dnFooter-col-sm-3">
<h5>Follow us</h5>
<div class="social-networks">
<a href="https://twitter.com/dailynation" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/DailyNation/" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.instagram.com/dailynation/" target="_blank"><i class="fa fa-instagram" aria-hidden="true"></i></a>
<a href="https://www.youtube.com/user/DNKenya" target="_blank"><i class="fa fa-youtube" aria-hidden="true"></i></a>
<a href="/sports/football/1102-1102-view-asFeed-wsedn1/index.xml"><i class="fa fa-rss-square" aria-hidden="true"></i></a></div>
<h1 style="font-size: 0px; margin: 0px;">Daily Nation</h1>
</div>
</div>
</footer></footer><script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>	
	
			_sf_async_config.path = '/5232024';
		_sf_async_config.sections = 'sports,sports - football';_sf_async_config.authors = 'jeff kinyanjui';
	_sf_async_config.autoDetect=false;
    /** CONFIGURATION END **/
    (function(){
        function loadChartbeat() {
            var e = document.createElement('script');
            var n = document.getElementsByTagName('script')[0];
            e.type = 'text/javascript';
            e.async = true;
            e.src = '//static.chartbeat.com/js/chartbeat_video.js';
            n.parentNode.insertBefore(e, n);
        }
		var _cbv = window._cbv || (window._cbv = []);_cbv.push(['autoDetectYouTubeIframes']);
        loadChartbeat();
    })();
</script>
<script src="/code/view/DailyNation/-/3797660/-/11l9hi4/-/jquery-3.1.1.min.js.js"></script>
<script>window.jQuery || document.write('<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.0/jquery.min.js"><\/script>')</script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/3797660/-/11l9hi4/-/jquery-3.1.1.min.js.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/2151136/-/gcrtsk/-/main_final.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/2456274/-/i04jhl/-/globalvideo.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/1949300/-/3sj01m/-/lazyload.min.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/1954386/-/3t22jc/-/jquery.social.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/2627434/-/j1g52o/-/jquery-cross.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/2627436/-/j1g52q/-/sharebutton.min.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/3783924/-/11kk8l2/-/jquery-migrate.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/3783912/-/11kk8k4/-/camera.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/3783926/-/11kk8l4/-/jquery-owl.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/4124544/-/vn95vgz/-/ticker-v1.0.1.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/4125928/-/vn8dh4z/-/tabcontent.js"></script>
<script type="text/javascript" language="javascript" src="/code/view/DailyNation/-/4131258/-/vmora1z/-/showMore.js"></script>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
<script src="/code/view/DailyNation/-/3783932/-/11kk8lv/-/electionsScript-v1.0.6.js"></script>
<script src="https://secure.widget.cloud.opta.net/v3/v3.opta-widgets.js"></script>
<script>var opta_settings={subscription_id:'11b2b9ec8f805a62b48ae6b59caf131a',language:'en_GB',timezone:'Africa/Nairobi'};</script>
<script type="text/javascript">$(".fifaShowHide").click(function(){$(".fifaShowHide span").html($(".fifaShowHide span").html()=='Hide'?'Show':'Hide')});</script>
<meta name="google-site-verification" content="bpM21xTzIpu_rdMgMeiN9tKlX_lDX_N44hD_YFzbT1s" />
<meta property="fb:pages" content="105983259496" />
<script>window.fbAsyncInit=function(){FB.init({appId:'174023979648743',xfbml:!0,version:'v2.5'})};(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/sdk.js";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'));</script>
<script type="text/javascript">window._taboola=window._taboola||[];_taboola.push({article:'auto'});!function(e,f,u,i){if(!document.getElementById(i)){e.async=1;e.src=u;e.id=i;f.parentNode.insertBefore(e,f)}}(document.createElement('script'),document.getElementsByTagName('script')[0],'//cdn.taboola.com/libtrc/nationmediagroup-dailynation/loader.js','tb_loader_script');</script>
<script type="text/javascript">$(".right-corder-container-button").hover(function(){var aud=$('audio')[0];$(".long-text").addClass("show-long-text");if(aud.paused){aud.play();$(".paused").hide();$(".live").show()}else{aud.pause();$(".paused").show();$(".live").hide()}},function(){$(".long-text").removeClass("show-long-text");if(aud.paused){aud.play();$(".paused").hide();$(".live").show()}else{aud.pause();$(".paused").show();$(".live").hide()}});</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>var domainpaths=window.location.pathname.split('/');if(domainpaths[1]=="brandbook"||domainpaths.length<4||domainpaths[1]=="supplements"){}else{    (adsbygoogle=window.adsbygoogle||[]).push({          google_ad_client:"ca-pub-0846142691248784",          enable_page_level_ads:!0});    }</script>

<link rel="manifest" href="/manifest.json" /><script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script><script>var OneSignal=window.OneSignal||[];OneSignal.push(function(){OneSignal.init({appId:"a5048fdb-e42b-462c-9ed3-11711cf05bad",})});</script>

<script type="text/javascript">
window.bk_async=function(){!function(t,a){var e="|"+t.meta_all.join("|")+"|";if(bk_addPageCtx("meta_all",e),a)for(metaTag in t.meta_kvp){var n=metaTag.replace(/[^0-9,a-zA-Z_]+/g,"_");bk_addPageCtx("meta_"+n,t.meta_kvp[metaTag])}}(function(){for(var t={meta_all:[],meta_kvp:{}},a=document.getElementsByTagName("meta"),e=0;e<a.length;e++)if(a[e].getAttribute("name")){var n=a[e].getAttribute("name"),o=a[e].getAttribute("content");t.meta_kvp[n]=o,t.meta_all.push(o)}else if(a[e].getAttribute("property")){var n=a[e].getAttribute("property"),o=a[e].getAttribute("content");t.meta_kvp[n]=o,t.meta_all.push(o)}return t}(),!1),bk_allow_multiple_calls=!0,bk_use_multiple_iframes=!0,window._bk=window._bk||{},window._bk.functions=window._bk.functions||{},window._bk.functions.socialTracker=function(t){"function"==typeof jQuery&&jQuery("[class*="+t+"]").mousedown(function(){var t=jQuery(this).attr("class").split(" ").slice(-1)[0];bk_addPageCtx("event","social_click"),bk_addPageCtx("social_name",t),BKTAG.doTag("80211",4)})},window._bk.functions.socialTracker("facebook"),window._bk.functions.socialTracker("whatsapp"),window._bk.functions.socialTracker("linkedin"),window._bk.functions.socialTracker("twitter"),window._bk.functions.socialTracker("instagram"),window._bk.functions.socialTracker("youtube"),bk_addPageCtx("url1",document.location.hostname+document.location.pathname),bk_addPageCtx("url2",document.location.hostname+document.location.pathname),bk_addPageCtx("url3",document.location.hostname+document.location.pathname),bk_addPageCtx("path1",document.location.pathname),bk_addPageCtx("path2",document.location.pathname),bk_addPageCtx("path3",document.location.pathname),BKTAG.doTag("80211",4)},function(){var t=document.getElementsByTagName("script")[0],a=document.createElement("script");a.async=!0,a.src="https://tags.bkrtx.com/js/bk-coretag.js",t.parentNode.insertBefore(a,t)}();
</script>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineOutOfPageSlot('/1010816/Z-DN-RoadBlock', 'div-gpt-ad-1546077479768-0').addService(googletag.pubads());
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1546077479768-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1546077479768-0'); });
</script>
</div></body>
</html>